您的位置:首页 > 理论基础 > 数据结构算法

【Jason's_ACM_解题报告】Quadtrees

2015-02-17 11:28 417 查看

Quadtrees 

A quadtree is a representation format used to encode images. The fundamental idea behind the quadtree is that any image can be split into four quadrants. Each quadrant may again be split in four sub quadrants, etc. In the quadtree, the image is represented
by a parent node, while the four quadrants are represented by four child nodes, in a predetermined order.

Of course, if the whole image is a single color, it can be represented by a quadtree consisting of a single node. In general, a quadrant needs only to be subdivided if it consists of pixels of different colors. As a result, the quadtree need not be of uniform
depth.

A modern computer artist works with black-and-white images of  tex2html_wrap_inline34 units, for a total of 1024 pixels per image. One of the operations he performs is adding two images together, to form a new image. In the resulting image a pixel is black
if it was black in at least one of the component images, otherwise it is white.

This particular artist believes in what he calls the preferred fullness: for an image to be interesting (i.e. to sell for big bucks) the most important property is the number of filled (black) pixels in the image. So, before adding two images together, he would
like to know how many pixels will be black in the resulting image. Your job is to write a program that, given the quadtree representation of two images, calculates the number of pixels that are black in the image, which is the result of adding the two images
together.

In the figure, the first example is shown (from top to bottom) as image, quadtree, pre-order string (defined below) and number of pixels. The quadrant numbering is shown at the top of the figure.



Input

The first line of input specifies the number of test cases (N) your program has to process.

The input for each test case is two strings, each string on its own line. The string is the pre-order representation of a quadtree, in which the letter 'p' indicates a parent node, the letter 'f' (full) a black quadrant and the letter 'e' (empty) a white quadrant.
It is guaranteed that each string represents a valid quadtree, while the depth of the tree is not more than 5 (because each pixel has only one color).

Output 

For each test case, print on one line the text 'There are X black pixels.', where X is the number of black pixels in the resulting image.

Sample Input

3

ppeeefpffeefe

pefepeefe

peeef

peefe

peeef

peepefefe

Sample Output

There are 640 black pixels.

There are 512 black pixels.

There are 384 black pixels.

这道题不必建树,建树相反还会变得更加麻烦,由于一共有1024个像素块儿,所以我们可以按照这个四分树将图片构建出来。然后统计所有黑色块儿的个数,技巧是边构图边计算。

附代码如下:
#include<cstdio>
#include<cstring>

using namespace std;

char s[1100];
int buf[32][32];
int ans;

void draw(const char* s,int& pos,int x,int y,int width){
char ch=s[pos++];
if(ch=='p'){
draw(s,pos,x,y+width/2,width/2);
draw(s,pos,x,y,width/2);
draw(s,pos,x+width/2,y,width/2);
draw(s,pos,x+width/2,y+width/2,width/2);
}else if(ch=='f'){
for(int i=x;i<x+width;i++){
for(int j=y;j<y+width;j++){
if(buf[i][j]==0){
buf[i][j]=1;
ans++;
}
}
}
}
}

int main(){
int total;
scanf("%d",&total);
while(total--){
memset(buf,0,sizeof(buf));
ans=0;
for(int i=0;i<2;i++){
scanf("%s",s);
int pos=0;
draw(s,pos,0,0,32);
}
printf("There are %d black pixels.\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  数据结构 构图