您的位置:首页 > 理论基础 > 数据结构算法

【Jason's_ACM_解题报告】Oil Deposits

2015-02-18 07:48 441 查看

Oil Deposits 

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each
plot separately, using sensing equipment to determine whether or not the plot contains oil.

A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a
grid.

Input 

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1<=m<=100 and  1<=n<=100. Following this
are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

Output 

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input 

1 1

*

3 5

*@*@*

**@**

*@*@*

1 8

@@****@*

5 5

****@

*@@*@

*@**@

@@@*@

@@**@

0 0

Sample Output 

0

1

2

2

FloodFill练习,小技巧,二重循环控制八个方向。

附代码如下:
#include<cstdio>
#include<cstring>

using namespace std;

#define MAXN (100+5)

int n,m;
char oil[MAXN][MAXN];
int idx[MAXN][MAXN];

void dfs(int x,int y,int num){
if(x<0||x>=n||y<0||y>=m)return;
if(idx[x][y]||oil[x][y]!='@')return;
idx[x][y]=num;
for(int i=-1;i<=1;i++){
for(int j=-1;j<=1;j++){
if(i||j)dfs(x+i,y+j,num);
}
}
}

int main(){
while(scanf("%d%d",&n,&m)==2&&n&&m){
for(int i=0;i<n;i++)scanf("%s",oil[i]);
int tot=0;
memset(idx,0,sizeof(idx));
for(int i=0;i<n;i++){
for(int j=0;j<m;j++){
if(oil[i][j]=='@'&&!idx[i][j])dfs(i,j,++tot);
}
}
printf("%d\n",tot);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息