您的位置:首页 > 其它

【Jason's_ACM_解题报告】A Spy in the Metro

2015-03-02 21:43 405 查看

A Spy in the Metro

Secret agent Maria was sent to Algorithms City to carry out an especially dangerous mission. After several thrilling events we find her in the first station of Algorithms City Metro, examining the time table. The Algorithms City Metro consists of a single line
with trains running both ways, so its time table is not complicated.

Maria has an appointment with a local spy at the last station of Algorithms City Metro. Maria knows that a powerful organization is after her. She also knows that while waiting at a station, she is at great risk of being caught. To hide in a running train is
much safer, so she decides to stay in running trains as much as possible, even if this means traveling backward and forward. Maria needs to know a schedule with minimal waiting time at the stations that gets her to the last station in time for her appointment.
You must write a program that finds the total waiting time in a best schedule for Maria.

The Algorithms City Metro system has N stations, consecutively numbered from 1 to N. Trains move in both directions: from the first station to the last station and from the last station back to the first station. The time required for a train to travel between
two consecutive stations is fixed since all trains move at the same speed. Trains make a very short stop at each station, which you can ignore for simplicity. Since she is a very fast agent, Maria can always change trains at a station even if the trains involved
stop in that station at the same time.



Input 

The input file contains several test cases. Each test case consists of seven lines with information as follows.

Line 1.

The integer N ( 2<=N<=50), which is the number of stations.

Line 2.

The integer T ( 0<=T<=200), which is the time of the appointment.

Line 3.

N - 1 integers: t1, t2,..., tN - 1 ( 1<=ti<=70), representing the travel times for the trains between two consecutive stations: t1 represents the travel time between the first two stations, t2 the time between the second and the third station, and so on.

Line 4.

The integer M1 ( 1<=M1<=50), representing the number of trains departing from the first station.

Line 5.

M1 integers: d1, d2,..., dM1 ( 0<=di<=250 and di < di + 1), representing the times at which trains depart from the first station.

Line 6.

The integer M2 ( 1<=M2<=50), representing the number of trains departing from the N-th station.

Line 7.

M2 integers: e1, e2,..., eM2 ( 0<=ei<=250 and ei < ei + 1) representing the times at which trains depart from the N-th station.

The last case is followed by a line containing a single zero.

Output 

For each test case, print a line containing the case number (starting with 1) and an integer representing the total waiting time in the stations for a best schedule, or the word `impossible' in case Maria is unable to make the appointment. Use the format of
the sample output.

Sample Input 

4

55

5 10 15

4

0 5 10 20

4

0 5 10 15

4

18

1 2 3

5

0 3 6 10 12

6

0 3 5 7 12 15

2

30

20

1

20

7

1 3 5 7 11 13 17

0

Sample Output 

Case Number 1: 5

Case Number 2: 0

Case Number 3: impossible

如果说硬要深究动态规划的分类的话,完全可以说此题是DAG上的最短路动态规划。

这道题的启发很大,时间是天然的“序”,此题一上来完全没有思路,但是受到Liu的启发,发现,这类题以时间为突破口,可以很好的解决。

定义d[i][j]表示,当前在时间i、车站j所需要等待的最短时间。那么d[0][1]就是需要求得的答案,d[T]
状态下,显然已经成功到达目的地,值为0。

那么我们分析在这个状态下,可以做哪些决策:

首先,如果没有车立刻靠站,我们可以等待,等待一辆车的到来。此时可以有状态转移方程:d[i][j]=d[i+1][j]+1;

其次,如果有车立刻靠站,那么我们看是向左开的还是向右开的车,并作出抉择。

最重要的一点是,构造has_train[][][]数组,其中第一维表示当前时间,第二维表示当前站点,第三维表示车辆方向。构造方法很简单,不再赘述。

附代码如下:
#include<cstdio>
#include<cstring>

#include<algorithm>

using namespace std;

#define MAXN (50+5)
#define MAXT (200+5)
#define OO (1000000000)
#define CLR(x,y) (memset(x,y,sizeof(x)))

int n,T;
int t[MAXN],dp[MAXT][MAXN];
bool has_train[MAXT][MAXN][2];

int main(){
int K=0;
while(scanf("%d",&n)==1&&n){

CLR(has_train,false);
CLR(dp,0);
scanf("%d",&T);
for(int i=1;i<=n-1;i++)scanf("%d",&t[i]);

int m;
scanf("%d",&m);
while(m--){
int d;
scanf("%d",&d);
for(int i=1;i<n;i++){
has_train[d][i][0]=true;
989b

d+=t[i];
}
}

scanf("%d",&m);
while(m--){
int d;
scanf("%d",&d);
for(int i=n;i>1;i--){
has_train[d][i][1]=true;
d+=t[i-1];
}
}

for(int i=1;i<=n;i++)dp[T][i]=OO;
dp[T]
=0;
for(int i=T-1;i>=0;i--){
for(int j=1;j<=n;j++){
dp[i][j]=dp[i+1][j]+1;
if(j<n&&has_train[i][j][0]&&i+t[j]<=T){
dp[i][j]=min(dp[i][j],dp[i+t[j]][j+1]);
}
if(j>1&&has_train[i][j][1]&&i+t[j-1]<=T){
dp[i][j]=min(dp[i][j],dp[i+t[j-1]][j-1]);
}
}
}

if(dp[0][1]>=OO)printf("Case Number %d: impossible\n",++K);
else printf("Case Number %d: %d\n",++K,dp[0][1]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息