您的位置:首页 > 其它

poj 3071Football(概率dp)

2015-02-06 02:14 337 查看
Football

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3340 Accepted: 1713
Description

Consider a single-elimination football tournament involving 2n teams, denoted 1, 2, …, 2n. In each round of the tournament, all teams still in the tournament are placed in a list in order of increasing index. Then,
the first team in the list plays the second team, the third team plays the fourth team, etc. The winners of these matches advance to the next round, and the losers are eliminated. After n rounds, only one team remains undefeated; this team is declared
the winner.

Given a matrix P = [pij] such that pij is the probability that team i will beat team j in a match determine which team is most likely to win the tournament.

Input

The input test file will contain multiple test cases. Each test case will begin with a single line containing n (1 ≤ n ≤ 7). The next 2n lines each contain 2n values; here, the jth value
on the ith line represents pij. The matrix P will satisfy the constraints that pij = 1.0 − pji for all i ≠ j, and pii = 0.0 for all i.
The end-of-file is denoted by a single line containing the number −1. Note that each of the matrix entries in this problem is given as a floating-point value. To avoid precision problems, make sure that you use either the 
double
 data type instead
of 
float
.

Output

The output file should contain a single line for each test case indicating the number of the team most likely to win. To prevent floating-point precision issues, it is guaranteed that the difference in win probability for the top two teams will be at least
0.01.

Sample Input
2
0.0 0.1 0.2 0.3
0.9 0.0 0.4 0.5
0.8 0.6 0.0 0.6
0.7 0.5 0.4 0.0
-1

Sample Output
2

Hint

In the test case above, teams 1 and 2 and teams 3 and 4 play against each other in the first round; the winners of each match then play to determine the winner of the tournament. The probability that team 2 wins the tournament in this case is:

P(2 wins) = P(2 beats 1)P(3 beats 4)P(2 beats 3) + P(2 beats 1)P(4 beats 3)P(2 beats 4)

= p21p34p23 + p21p43p24

= 0.9 · 0.6 · 0.4 + 0.9 · 0.4 · 0.5 = 0.396.
The next most likely team to win is team 3, with a 0.372 probability of winning the tournament.

Source

Stanford Local 2006

概率dp

dp[i][j]为在第i次比赛中j队获胜的概率

dp[i][j]=dp[i-1][j]*p0[i][j] p0[i][j]为第i轮获胜的概率

p0[i][j]=∑p[j][k]*dp[i-1][k]

关于k的取值,我们观察发现如果按照2^(i-1)划分区域,那么第1个区域的队伍在第i轮只可能和第2个区域的对战。

每轮对每一队所属区域标号为(i-1)/2^(i-1)+1
#include<stdio.h>
#include<stdlib.h>
#include<math.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<stack>
#include<string>
#define MAX 1005
#define INF 1000000
using namespace std;
double dp[10][150],p[150][150],p0[10][150];
int main(void)
{
int n,tm;
double mx;
int mxi;
int i,j,k,l;
int flag;
while(scanf("%d",&n)&&(n+1))
{
memset(dp,0,sizeof(dp));
memset(p,0,sizeof(p));
memset(p0,0,sizeof(p0));
tm=1<<n;
for(i=1;i<=tm;i++)
for(j=1;j<=tm;j++)
scanf("%lf",&p[i][j]);
for(i=1;i<=tm;i++)dp[0][i]=1;

<span style="white-space:pre">	</span>for(i=1;i<=n;i++)
for(j=1;j<=tm;j++)
{
flag=(j-1)/(1<<(i-1))+1;
if(flag&1)l=flag*(1<<(i-1))+1;
else l=(flag-2)*(1<<(i-1))+1;
for(k=l;k<=l+(1<<(i-1))-1;k++)
p0[i][j]+=p[j][k]*dp[i-1][k];
dp[i][j]=dp[i-1][j]*p0[i][j];
}
mxi=1;mx=dp
[1];
for(i=2;i<=tm;i++)
if(dp
[i]>mx)
{
mx=dp
[i];
mxi=i;
}
printf("%d\n",mxi);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm dp 概率dp PKU