您的位置:首页 > 其它

1102最小生成树

2015-02-02 19:41 337 查看
【科普】什么是BestCoder?如何参加?

Constructing Roads

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 15081 Accepted Submission(s): 5759



Problem Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B,
or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.



Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within
[1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.



Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.



Sample Input
3
0 990 692
990 0 179
692 179 0
1
1 2




Sample Output
179


#include <stdio.h>
#include <algorithm>
using namespace std;
#include <string.h>
#define inf 0x6ffffff//最大值
int vis[102];
int map[102][102];
int dis[102];
int n,sum;
//创建map二维数组储存图表,dis数组记录每2个点间最小权值,vis数组标记某点是否已访问
void prim()
{
    int i,j,k,min;
    for(i=1; i<=n; i++)
        dis[i]=map[1][i];
    vis[1]=1;
    for(i=1; i<=n; i++)
    {
        min=inf;
        for(j=1;j<=n;j++)
        {
            if(vis[j]==0&&dis[j]<min)
            {
                min=dis[j];
                k=j;
            }
        }
        if(min==inf)
            break;
        vis[k]=1;
        sum=sum+min;
        for(j=1;j<=n;j++)
        {
            if(vis[j]==0&&dis[j]>map[k][j])
                dis[j]=map[k][j];
        }
    }
}
int main()
{
    int ll,i,j,str,end,m;
    while(scanf("%d",&n)!=EOF)
    {
        memset(vis,0,sizeof(vis));
        memset(dis,0,sizeof(dis));
        for(i=1; i<=n; i++)
        {
            for(j=1; j<=n; j++)
            {
                map[i][j]=inf;
            }
        }//现将所有距离都设置成最大
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=n;j++)
            {
                scanf("%d",&ll);
                if(map[i][j]>ll)
                    map[i][j]=map[j][i]=ll;
            }
        }
        scanf("%d",&m);
        for(i=1;i<=m;i++)
        {
            scanf("%d%d",&str,&end);
            map[str][end]=map[end][str]=0;   //这里必须是双向的。不能写成	map[str][end]=0。因为这里WA了两次
        }
        sum=0;
        prim();
        printf("%d\n",sum);
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: