您的位置:首页 > 其它

【杭电oj】1102 - Constructing Roads(畅通工程,最小生成树)

2016-01-05 21:17 323 查看


Constructing Roads

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 18366 Accepted Submission(s): 7018



Problem Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village
C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.



Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village
i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.



Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.



Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2




Sample Output

179




Source

kicc

仍然是最小生成树。

代码如下:

#include <stdio.h>
#include <algorithm>
using namespace std;
int set[1111];
struct str
{
	int st,end,length;
}data[5000];

bool cmp(str a,str b)
{
	return a.length<b.length;
}

int find(int x)
{
	int r=x;
	while (r!=set[r])
		r=set[r];
	int j=x;
	int i;
	while (j!=r)
	{
		i=set[j];
		set[j]=r;
		j=i;
	}
	return r;
}

int join(int x,int y)
{
	int fx,fy;
	fx=find(x);
	fy=find(y);
	if (fx!=fy)
	{
		set[fy]=fx;
		return 1;		//不一棵树返回1 
	}
	return 0;
}

int main()
{
	int n;		//村庄数
	int ans;
	int num;
	int m;
	while (~scanf ("%d",&n) && n) 
	{
		m=n*(n-1)/2;
		num=1;
		for (int i=1;i<=n;i++)
		{
			for (int j=1;j<=n;j++)
			{
				if (j>i)
				{
					data[num].st=i;
					data[num++].end=j;
				}
			}	
		}
		num=1;
		int p;
		for (int i=1;i<=n;i++)
		{
			for (int j=1;j<=n;j++)
			{
				if (j>i)
					scanf ("%d",&data[num++].length);
				else
					scanf ("%d",&p);
			}
		} 
		for (int i=1;i<=n;i++)
			set[i]=i;
		ans=0;
		int t;		//t条路已修成 
		scanf ("%d",&t);
		int t1,t2;
		while (t--)
		{
			scanf ("%d%d",&t1,&t2);
			join(t1,t2);
		}
		sort(data+1,data+1+m,cmp);
		for (int i=1;i<=m;i++)
		{
			if (join (data[i].st,data[i].end))		//不在同一棵树,合并,并把距离记录 
			{
				ans+=data[i].length;
			}
		}
		printf ("%d\n",ans);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: