您的位置:首页 > 其它

HDOJ题目1102Constructing Roads(最小生成树,prim)

2014-08-12 20:21 351 查看

Constructing Roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 14031    Accepted Submission(s): 5340


[align=left]Problem Description[/align]
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B,
or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

 

[align=left]Input[/align]
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within
[1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

 

[align=left]Output[/align]
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

 

[align=left]Sample Input[/align]

3
0 990 692
990 0 179
692 179 0
1
1 2

 

[align=left]Sample Output[/align]

179

 

[align=left]Source[/align]
kicc

 

[align=left]Recommend[/align]
Eddy   |   We have carefully selected several similar problems for you:  1301 1162 1856 1217 3371 
 

以前用kruskal写的,,,再用prim写一回

ac代码

#include<stdio.h>
#include<string.h>
#define INF 0xfffffff
int map[200][200],v[100000];
int main()
{
int n;
while(scanf("%d",&n)!=EOF)
{
int i,j,d,m,sum=0,min,flag;
memset(v,0,sizeof(v));
for(i=1;i<=n;i++)
{
for(j=1;j<=n;j++)
map[i][j]=INF;
}
for(i=1;i<=n;i++)
{
for(j=1;j<=n;j++)
{
scanf("%d",&d);
if(d<map[i][j])
map[i][j]=d;
}
}
scanf("%d",&m);
while(m--)
{
int a,b;
scanf("%d%d",&a,&b);
map[a][b]=map[b][a]=0;
}
v[1]=1;
for(i=2;i<=n;i++)
{
min=INF;
flag=-1;
for(j=1;j<=n;j++)
{
if(!v[j]&&map[1][j]<min)
{
min=map[1][j];
flag=j;
}
}
if(flag==-1)
break;
sum+=map[1][flag];
v[flag]=1;
for(j=1;j<=n;j++)
{
if(!v[j]&&map[1][j]>map[flag][j])
map[1][j]=map[flag][j];
}
}
printf("%d\n",sum);
}
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: