您的位置:首页 > 大数据 > 人工智能

POJ 1422 && ZOJ 1525 --Air Raid【二分图 && 最小路径覆盖】

2015-08-25 21:03 761 查看
Air Raid

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 7451Accepted: 4434
Description

Consider a town where all the streets are one-way and each street leads from one intersection to another. It is also known that starting from an intersection and walking through town's streets you can never reach the same intersection i.e. the town's streets
form no cycles.

With these assumptions your task is to write a program that finds the minimum number of paratroopers that can descend on the town and visit all the intersections of this town in such a way that more than one paratrooper visits no intersection. Each paratrooper
lands at an intersection and can visit other intersections following the town streets. There are no restrictions about the starting intersection for each paratrooper.

Input

Your program should read sets of data. The first line of the input file contains the number of the data sets. Each data set specifies the structure of a town and has the format:

no_of_intersections

no_of_streets

S1 E1

S2 E2

......

Sno_of_streets Eno_of_streets

The first line of each data set contains a positive integer no_of_intersections (greater than 0 and less or equal to 120), which is the number of intersections in the town. The second line contains a positive integer no_of_streets, which is the number of streets
in the town. The next no_of_streets lines, one for each street in the town, are randomly ordered and represent the town's streets. The line corresponding to street k (k <= no_of_streets) consists of two positive integers, separated by one blank: Sk (1 <= Sk
<= no_of_intersections) - the number of the intersection that is the start of the street, and Ek (1 <= Ek <= no_of_intersections) - the number of the intersection that is the end of the street. Intersections are represented by integers from 1 to no_of_intersections.

There are no blank lines between consecutive sets of data. Input data are correct.

Output

The result of the program is on standard output. For each input data set the program prints on a single line, starting from the beginning of the line, one integer: the minimum number of paratroopers required to visit all the intersections in the town.

Sample Input
2
4
3
3 4
1 3
2 3
3
3
1 3
1 2
2 3

Sample Output
2
1


题意:一个地图上有n个小镇,以及m个连接着其中两个小镇的有向边,而且这些边无法形成回路。现在选择一些小镇空降士兵(1个小镇最多1个士兵),士兵能沿着边走到尽头,问最少空降几个士兵,能遍历完所有的小镇。

解析:裸的不能再裸的最小路径覆盖问题,先说一下什么是最小路径覆盖:

在一个有向图中,路径覆盖就是在图中找一些路径,使之覆盖了图中的所有顶点,且任何一个顶点有且只有一条路径与之关联;(如果把这些路径中的每条路径从它的起始点走到它的终点,那么恰好可以经过图中的每个顶点一次且仅一次)。

首先我们建立二分图,一个城市当做一个节点, 我们首先把一个节点拆成两个节点,分左右两部分,相连的节点建边,求求最大匹配数。

二分图的最小路径覆盖 = 二分图的顶点 - 二分图的最大匹配数。

#include <cstdio>
#include <cstring>
#include <algorithm>
#define maxn 200
using namespace std;
int map[maxn][maxn];
int used[maxn];
int link[maxn];
int n, m;

void init(){
    memset(map, 0, sizeof(map));
}

void getmap(){
    scanf("%d%d", &n, &m);
    while(m--){
        int a, b;
        scanf("%d%d", &a, &b);
        map[a][b] = 1;
    }
}

bool dfs(int x){
    for(int i = 1; i <= n; ++i){
        if(map[x][i] && !used[i]){
            used[i] = 1;
            if(link[i] == -1 || dfs(link[i])){
                link[i] = x;
                return true;
            }
        }
    }
    return false;
}

int hungary(){
    int ans = 0;
    memset(link, -1, sizeof(link));
    for(int i = 1; i <= n; ++i){
        memset(used, 0, sizeof(used));
        if(dfs(i))
            ans++;
    }
    return ans;
}

int main (){
    int T;
    scanf("%d", &T);
    while(T--){
        init();
        getmap();
        int sum = hungary();
        //printf("%d\n", sum);
        printf("%d\n", n - sum);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: