您的位置:首页 > 其它

HDOJ 1102 Constructing Roads(最小生成树--prime)

2015-08-11 15:23 351 查看

Constructing Roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 17111    Accepted Submission(s): 6489


[align=left]Problem Description[/align]
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B,
or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

 

[align=left]Input[/align]
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within
[1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

 

[align=left]Output[/align]
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

 

[align=left]Sample Input[/align]

3
0 990 692
990 0 179
692 179 0
1
1 2

 

[align=left]Sample Output[/align]

179

ac代码:
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<math.h>
#include<algorithm>
#define max(a,b) a>b?a:b
#define MAXN 101
#define INF 0xfffffff
using namespace std;
int pri[MAXN][MAXN];
int v[MAXN];
int dis[MAXN];
int sum,n;
void prime()
{
int k,i,j;
int M;
memset(v,0,sizeof(v));
v[1]=1;
sum=0;
for(i=1;i<=n;i++)
{
dis[i]=pri[1][i];
}
for(i=0;i<n;i++)
{
M=INF;
for(j=1;j<=n;j++)
{
if(v[j]==0&&dis[j]<M)
{
M=dis[j];
k=j;
}
}
if(M==INF)
break;
v[k]=1;
sum+=M;
for(j=1;j<=n;j++)
{
if(v[j]==0&&pri[k][j]<dis[j])
dis[j]=pri[k][j];
}
}
}
int main()
{
int i,j,q,a,b,k;
while(scanf("%d",&n)!=EOF)
{
for(i=1;i<=n;i++)
{
for(j=1;j<=n;j++)
{
scanf("%d",&k);
pri[i][j]=pri[j][i]=k;
}
}
scanf("%d",&q);
for(i=1;i<=q;i++)
{
scanf("%d%d",&a,&b);
pri[a][b]=pri[b][a]=0;//记录有路,所以权值为0,不影响sum
}
prime();
printf("%d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: