您的位置:首页 > 其它

UVAlive 4857 - Halloween Costumes 区间dp

2014-08-09 18:26 302 查看



4857 - Halloween Costumes

Gappu has a very busy weekend ahead of him. Because, next weekend is Halloween, and he is planning to attend as many parties as he can. Since it's Halloween, these parties are all costume parties, Gappu always selects
his costumes in such a way that it blends with his friends, that is, when he is attending the party, arranged by his comic-book-fan friends, he will go with the costume of Superman, but when the party is arranged contestbuddies, he would go with the costume
of `Chinese Postman'.



Since he is going to attend a number of parties on the Halloween night, and wear costumes accordingly, he will be changing his costumes a number of times. So, to make things a little easier, he may put on costumes
one over another (that is he may wear the uniform for the postman, over the superman costume). Before each party he can take off some of the costumes, or wear a new one. That is, if he is wearing the Postman uniform over the Superman costume, and wants to
go to a party in Superman costume, he can take off the Postman uniform, or he can wear a new Superman uniform. But, keep in mind that, Gappu doesn't like to wear dresses without cleaning them first, so, after taking off the Postman uniform, he cannot use that
again in the Halloween night, if he needs the Postman costume again, he will have to use a new one. He can take off any number of costumes, and if he takes off k of the costumes, that will be the last k ones
(e.g. if he wears costume A before costume B, to take off A, first he has to remove B).
Given the parties and the costumes, find the minimum number of costumes Gappu will need in the Halloween night.

Input

First line contains T (T

2500),
the number of test cases.
Each test case starts with two integers, N and M (1

N, M

100),
the number of parties, and number of different types of costumes. Next line contains N integers, ci (1

ci

M),
the costume he will be wearing in party i. He will attend the party 1 first, then party 2, and so on.
There is a blank line before each test case.

Output

For each test case, output the minimum number of required costumes. Look at the output for sample input for details.

Sample Input

4

1 1
1

2 2
1 1

3 2
1 2 1

7 3
1 2 1 1 3 2 1


Sample Output

Case 1: 1
Case 2: 1
Case 3: 2
Case 4: 4


题意:有n个party,m件礼服,每个party有要求的礼服,礼服可以套在身上穿,但是脱下来的礼服就不能再次穿,类似堆栈,求需要的最少衣服数量。
这题就相当于查找区间内的括号对数,每一对括号就相当于可以少带一件衣服,结果自然就是n-ans(1,n)了。只要想明白了,很典型的区间dp

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int a[105];
int dp[105][105];
int ans(int l,int r)
{
if(l>r)return 0;
if(dp[l][r]!=-1)
return dp[l][r];
dp[l][r]=max(ans(l+1,r),ans(l,r-1));
if(a[l]==a[r])
dp[l][r]=max(dp[l][r],ans(l+1,r-1)+1);
for(int k=l;k<=r;k++)
dp[l][r]=max(dp[l][r],ans(l,k)+ans(k,r));
return dp[l][r];
}
int main()
{
int t,n,m,cas=1;
scanf("%d",&t);
while(t--){
scanf("%d%d",&n,&m);
for(int i=1;i<=n;i++)scanf("%d",&a[i]);
memset(dp,-1,sizeof(dp));
for(int i=0;i<=n;i++) dp[i][i]=0;
int s=n-ans(1,n);
printf("Case %d: %d\n",cas++,s);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: