您的位置:首页 > 其它

Stacking Boxes - UVa 103 dp

2014-07-24 16:53 423 查看


Stacking Boxes

Background

Some concepts in Mathematics and Computer Science are simple in one or two dimensions but become more complex when extended to arbitrary dimensions. Consider solving differential equations in several dimensions
and analyzing the topology of an n-dimensional hypercube. The former is much more complicated than its one dimensional relative while the latter bears a remarkable resemblance to its ``lower-class'' cousin.

The Problem

Consider an n-dimensional ``box'' given by its dimensions. In two dimensions the box (2,3) might represent a box with length 2 units and width 3 units. In three dimensions the box (4,8,9) can represent
a box

(length, width, and height). In 6 dimensions it is, perhaps, unclear what the box (4,5,6,7,8,9) represents; but we can analyze
properties of the box such as the sum of its dimensions.
In this problem you will analyze a property of a group of n-dimensional boxes. You are to determine the longest nesting string of boxes, that is a sequence of boxes

such
that each box

nests in box

(

.
A box D = (

) nests in a box E = (

)
if there is some rearrangement of the

such that when rearranged each dimension is less than the corresponding dimension in box
E. This loosely corresponds to turning box D to see if it will fit in box E. However, since any rearrangement suffices, box D can be contorted, not just turned (see examples below).
For example, the box D = (2,6) nests in the box E = (7,3) since D can be rearranged as (6,2) so that each dimension is less than the corresponding dimension in E. The box D = (9,5,7,3) does NOT nest in the box E
= (2,10,6,8) since no rearrangement of D results in a box that satisfies the nesting property, but F = (9,5,7,1) does nest in box E since F can be rearranged as (1,9,5,7) which nests in E.
Formally, we define nesting as follows: box D = (

) nests in box E = (

)
if there is a permutation

of

such
that (

) ``fits'' in (

)
i.e., if

for all

.

The Input

The input consists of a series of box sequences. Each box sequence begins with a line consisting of the the number of boxes k in the sequence followed by the dimensionality of the boxes, n (on
the same line.)
This line is followed by k lines, one line per box with the n measurements of each box on one line separated by one or more spaces. The

line
in the sequence (

) gives the measurements for the

box.
There may be several box sequences in the input file. Your program should process all of them and determine, for each sequence, which of the k boxes determine the longest nesting string and the length of
that nesting string (the number of boxes in the string).
In this problem the maximum dimensionality is 10 and the minimum dimensionality is 1. The maximum number of boxes in a sequence is 30.

The Output

For each box sequence in the input file, output the length of the longest nesting string on one line followed on the next line by a list of the boxes that comprise this string in order. The ``smallest'' or ``innermost''
box of the nesting string should be listed first, the next box (if there is one) should be listed second, etc.
The boxes should be numbered according to the order in which they appeared in the input file (first box is box 1, etc.).
If there is more than one longest nesting string then any one of them can be output.

Sample Input

5 2
3 7
8 10
5 2
9 11
21 18
8 6
5 2 20 1 30 10
23 15 7 9 11 3
40 50 34 24 14 4
9 10 11 12 13 14
31 4 18 8 27 17
44 32 13 19 41 19
1 2 3 4 5 6
80 37 47 18 21 9


Sample Output

5
3 1 2 4 5
4
7 2 5 6


题意:如果一个盒子的维度都可以装下另一个盒子,就可以让他们嵌套,问最多能嵌套多少层,分别是哪些盒子。

思路:每个盒子的维度先排序,然后所有盒子按最大维度排序,最大的相同时排第二大的。然后比较一个盒子更大时,就是排完序后这个盒子的维度比另一个都大。然后递推还是比较容易的,就是这类题目比较恶心。

AC代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int n,m,dp[1010],f[1010];
struct node
{ int d[12],num,to;
}box[1010];
bool cmp(node a,node b)
{ int i;
  for(i=m;i>=1;i--)
   if(a.d[i]<b.d[i])
    return true;
   else if(a.d[i]>b.d[i])
    return false;
  return true;
}
bool bigger(int a,int b)
{ int i;
  for(i=1;i<=m;i++)
   if(box[a].d[i]<=box[b].d[i])
    return false;
  return true;
}
int main()
{ int i,j,k,temp,ans,pos;
  while(~scanf("%d%d",&n,&m))
  { for(i=1;i<=n;i++)
    { for(j=1;j<=m;j++)
       scanf("%d",&box[i].d[j]);
      box[i].num=i;
      sort(box[i].d+1,box[i].d+1+m);
    }
    sort(box+1,box+1+n,cmp);
    memset(dp,0,sizeof(dp));
    dp[1]=1;
    box[1].to=0;
    for(i=2;i<=n;i++)
    { temp=0;
      for(j=1;j<i;j++)
       if(bigger(i,j) && dp[j]>=temp)
       { temp=dp[j];
         box[i].to=j;
       }
      dp[i]=temp+1;
      if(temp==0)
       box[i].to=0;
    }
    ans=0;pos=0;
    for(i=1;i<=n;i++)
     if(dp[i]>=ans)
     { ans=dp[i];
       pos=i;
     }
    for(i=ans;i>=1;i--)
    { f[i]=box[pos].num;
      pos=box[pos].to;
    }
    printf("%d\n",ans);
    if(n>0)
    { printf("%d",f[1]);;
      for(i=2;i<=ans;i++)
       printf(" %d",f[i]);
      printf("\n");
    }
  }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: