您的位置:首页 > 其它

UVA - 103 - Stacking Boxes (动态规划)

2015-03-31 23:24 281 查看
UVA - 103

Stacking Boxes

Time Limit: 3000MSMemory Limit: Unknown64bit IO Format: %lld & %llu
Submit Status

Description





Background

Some concepts in Mathematics and Computer Science are simple in one or two dimensions but become more complex when extended to arbitrary dimensions. Consider solving differential equations in several dimensions
and analyzing the topology of an n-dimensional hypercube. The former is much more complicated than its one dimensional relative while the latter bears a remarkable resemblance to its ``lower-class'' cousin.

The Problem

Consider an n-dimensional ``box'' given by its dimensions. In two dimensions the box (2,3) might represent a box with length 2 units and width 3 units. In three dimensions the box (4,8,9) can represent
a box

(length, width, and height). In 6 dimensions it is, perhaps, unclear what the box (4,5,6,7,8,9) represents; but we can analyze
properties of the box such as the sum of its dimensions.
In this problem you will analyze a property of a group of n-dimensional boxes. You are to determine the longest nesting string of boxes, that is a sequence of boxes

such
that each box

nests in box

(

.
A box D = (

) nests in a box E = (

)
if there is some rearrangement of the

such that when rearranged each dimension is less than the corresponding dimension in box
E. This loosely corresponds to turning box D to see if it will fit in box E. However, since any rearrangement suffices, box D can be contorted, not just turned (see examples below).
For example, the box D = (2,6) nests in the box E = (7,3) since D can be rearranged as (6,2) so that each dimension is less than the corresponding dimension in E. The box D = (9,5,7,3) does NOT nest in the box
E = (2,10,6,8) since no rearrangement of D results in a box that satisfies the nesting property, but F = (9,5,7,1) does nest in box E since F can be rearranged as (1,9,5,7) which nests in E.
Formally, we define nesting as follows: box D = (

) nests in box E =
(

) if there is a permutation

of

such
that (

) ``fits'' in (

)
i.e., if

for all

.

The Input

The input consists of a series of box sequences. Each box sequence begins with a line consisting of the the number of boxes k in the sequence followed by the dimensionality of the boxes, n (on
the same line.)
This line is followed by k lines, one line per box with the n measurements of each box on one line separated by one or more spaces. The

line
in the sequence (

) gives the measurements for the

box.
There may be several box sequences in the input file. Your program should process all of them and determine, for each sequence, which of the k boxes determine the longest nesting string and the length
of that nesting string (the number of boxes in the string).
In this problem the maximum dimensionality is 10 and the minimum dimensionality is 1. The maximum number of boxes in a sequence is 30.

The Output

For each box sequence in the input file, output the length of the longest nesting string on one line followed on the next line by a list of the boxes that comprise this string in order. The ``smallest'' or ``innermost''
box of the nesting string should be listed first, the next box (if there is one) should be listed second, etc.
The boxes should be numbered according to the order in which they appeared in the input file (first box is box 1, etc.).
If there is more than one longest nesting string then any one of them can be output.

Sample Input

5 2
3 7
8 10
5 2
9 11
21 18
8 6
5 2 20 1 30 10
23 15 7 9 11 3
40 50 34 24 14 4
9 10 11 12 13 14
31 4 18 8 27 17
44 32 13 19 41 19
1 2 3 4 5 6
80 37 47 18 21 9


Sample Output

5
3 1 2 4 5
4
7 2 5 6


Source

Root :: AOAPC I: Beginning Algorithm Contests (Rujia Liu) :: Volume 5. Dynamic Programming

Root :: Competitive Programming: Increasing the Lower Bound of Programming Contests (Steven & Felix Halim) :: Chapter 4. Graph :: Special Graph - DAG :: Single-Source
Shortest/Longest Paths in DAG

Root :: Competitive Programming 2: This increases the lower bound of Programming Contests. Again (Steven & Felix Halim) :: Graph :: Special Graph (Directed Acyclic Graph) :: Single-Source
Shortest/Longest Paths on DAG

Root :: Competitive Programming 3: The New Lower Bound of Programming Contests (Steven & Felix Halim) :: Graph :: Special Graph (Directed Acyclic Graph) :: Single-Source
Shortest/Longest Paths on DAG

Root :: Competitive Programming: Increasing the Lower Bound of Programming Contests (Steven & Felix Halim) :: Chapter 3. Problem Solving Paradigms :: Dynamic Programming :: Longest
Increasing Subsequence (LIS) - Classical
Submit Status

思路:将a数组每一维排序,如果有一列严格小于另一列,则可以构成一条有向边,构图之后再去寻找最长路。。

AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int n, k;
int a[32][12];
int map[32][32];
int d[32];
int flag;

int fun(int x, int y) {
	for(int i = 0; i < k; i++) {
		if(a[x][i] >= a[y][i]) return 0;
	}
	return 1;
}

int dp(int i) {
	int & ans = d[i];
	if(ans != -1) return ans;
	ans = 1;
	for(int j = 0; j < n; j++) 
		if(map[i][j]) {
			ans = max(ans, dp(j) + 1);
		}
	return ans;
} 

void print(int i) {
	if(flag) printf(" %d", i + 1);
	else {
		printf("%d", i + 1);
		flag = 1;
	}
	for(int j = 0; j < n; j++) 
		if(map[i][j] && d[i] == d[j] + 1) {
			print(j);
			break;
		}
}

int main() {
	while(scanf("%d %d", &n, &k) != EOF) {
		for(int i = 0; i < n; i++) {
			for(int j = 0; j < k; j++) {
				scanf("%d", &a[i][j]);
			}
			sort(a[i], a[i] + k);
		}
		
		memset(map, 0, sizeof(map));
		for(int i = 0; i < n - 1; i++) {
			for(int j = i + 1; j < n; j++) {
				if(fun(i, j)) map[i][j] = 1;
				else if(fun(j, i)) map[j][i] = 1;
			}
		}
		
		/*for(int i = 0; i < n; i++) {
			for(int j = 0; j < n; j++) {
				printf("%d ", map[i][j]);
			}
			printf("\n");
		}*/
		
		memset(d, -1, sizeof(d));
		int ans = -1, pos;
		for(int i = 0; i < n; i++) {
			int tmp = dp(i);
			if(tmp > ans) {
				ans = tmp; pos = i;
			}
		}
		
		flag = 0;
		printf("%d\n", ans);
		print(pos);
		printf("\n");
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: