您的位置:首页 > 其它

(二分图最大匹配) poj3041 Asteroids

2014-07-16 18:55 281 查看
Asteroids

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14464 Accepted: 7871
Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find
the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.
Input

* Line 1: Two integers N and K, separated by a single space. 

* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.
Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.
Sample Input
3 4
1 1
1 3
2 2
3 2

Sample Output
2

Hint

INPUT DETAILS: 

The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
X.X 

.X. 

.X. 

OUTPUT DETAILS: 

Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).
Source

USACO 2005 November Gold

这道题是如何转化成两个顶点集的呢?把x轴和y轴看做顶点,把小行星看做连接顶点的边(x,y),n*n的矩阵便转化为两个包含n个顶点的集合,即一个二分图。

题意便变成了选取最少的点覆盖所有的边,即最小点覆盖问题。

根据König定理,最小点覆盖数就是最大匹配数。

用匈牙利算法解决:

Memory 360K  Time 0MS

#include<stdio.h>
#include<string>
using namespace std;

bool map[505][505]={};
int n,k;
bool vis[505]={};
int id[505]={};
int m;

bool dfs(int x){
for (int i=1;i<=n;i++){
if(map[x][i] && !vis[i]){
vis[i]=true;
if (id[i]==0 || dfs(id[i])){
id[i]=x;
return true;
}
}
}
return false;
}

int main(){
scanf("%d%d",&n,&k);
m=0;
for(int i=0;i<k;i++){
int x,y;
scanf("%d%d",&x,&y);
map[x][y]=true;
}

for (int i=1;i<=n;i++){
memset(vis,0,sizeof(vis));
if (dfs(i))
m++;
}

printf("%d\n",m);

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: