您的位置:首页 > 其它

POJ3041——Asteroids(二分图最大匹配)

2013-03-18 21:37 232 查看
Asteroids
Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 11253Accepted: 6104
Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find
the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 

* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4

1 1

1 3

2 2

3 2

Sample Output

2

Hint

INPUT DETAILS: 

The following diagram represents the data, where "X" is an asteroid and "." is empty space: 

X.X 

.X. 

.X. 

OUTPUT DETAILS: 

Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

Source

USACO 2005 November Gold

解析:

         将行坐标看成一个集合,将列坐标看成一个集合。。。

         读入一个坐标就在该行和该列之间连边

         最后用匈牙利做匹配

代码:

 

#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
int n,k,pre[600],map[510][510],ret=0;
bool vis[510];

void readdata()
{
freopen("poj3041.in","r",stdin);
freopen("poj3041.out","w",stdout);
scanf("%d%d",&n,&k);
for(int i=1;i<=k;i++)
{
int x,y;
scanf("%d%d",&x,&y);
map[x][y]=1;
}
}

bool check(int u)
{
for(int j=1;j<=n;j++)
if(map[u][j] && !vis[j])
{
vis[j]=1;
if(pre[j]==-1 || check(pre[j]))
{
pre[j]=u;
return 1;
}
}
return 0;
}

void work()
{
memset(pre,255,sizeof(pre));
for(int i=1;i<=n;i++)
{
for(int j=1;j<=n;j++)vis[j]=0;
if(check(i))ret++;
}
cout<<ret<<endl;
}

int main()
{
readdata();
work();
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: