您的位置:首页 > 其它

Asteroids - poj 3041(二分图最大匹配问题)

2015-07-26 10:11 417 查看
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 17258Accepted: 9386
Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid.

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.
Input

* Line 1: Two integers N and K, separated by a single space.
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.
Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.
Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS:
The following diagram represents the data, where "X" is an asteroid and "." is empty space:
X.X
.X.
.X.

OUTPUT DETAILS:
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

这题利用的是二分图的最大匹配问题,将每一行,每一列看做一个点,将所有行构成的点组成一个集合,而所有列构成的的点看成一个集合,将输入的数据看成是连接两个集合的边,这样就是一个二分图了。

#include <iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int map[500][500];
int vis[500],match[500];
int m,n;
int DFS(int p){
int v;
for(int i=1;i<=m;i++){
if(map[p][i]&&!vis[i]){
vis[i]=1;
v=match[i];
if( v==-1 || DFS(v)){
match[i]=p;
return 1;
}

}
}
return 0;
}
int main() {
while(~scanf("%d %d",&m,&n)){
memset(map,0,500*500*sizeof(int));
for(int i=0;i<n;i++){
int a,b;
scanf("%d %d",&a,&b);
map[a][b]=1;
}
int result=0;
memset(match,-1,500*sizeof(int));
for(int i=1;i<=m;i++){
memset(vis,0,500*sizeof(int));
result+=DFS(i);
}
printf("%d\n",result);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: