您的位置:首页 > 其它

POJ 3041 Asteroids (匈牙利算法)

2014-07-10 17:06 274 查看

Asteroids

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 14388Accepted: 7828
Description
Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located
at the lattice points of the grid.

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find
the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.
Input
* Line 1: Two integers N and K, separated by a single space.

* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.
Output
* Line 1: The integer representing the minimum number of times Bessie must shoot.
Sample Input
3 4
1 1
1 3
2 2
3 2

Sample Output
2

(匈牙利算法模板) 匈牙利算法是解决寻找二分图最大匹配的。
#include <iostream>
using namespace std;
#define N 510
int g

,mark
,link
;
int n,x,y;
int dfs(int i)
{
    int j;
    for(j = 1;j<= y; j++)
    {
        if(g[i][j]&&!mark[j])            
        {
            
            mark[j] = 1;
            if(link[j]==-1||dfs(link[j]))
            {
                link[j] = i;               
                return 1;
            }
        }
    }
    return 0;                         
}   //完全是匈牙利算法模板。

int main()
{
    int i,sum = 0;
    int a,b;
    while(scanf("%d%d",&x,&n)!=EOF)
    {  y=x;
       memset(g,0,sizeof(g));
       sum=0;
       for(i=1;i<= n;i++)
       {
           scanf("%d%d",&a,&b);
           g[a][b]=1;
       }
       memset(link,-1,sizeof(link));   
       for(i = 1; i<=x; i++)
       {  
           memset(mark,0,sizeof(mark));  //最为重要的就是每次mark清零。
                                         //这么做是为了只保留link中对应匹配。
           if(dfs(i))   
               sum+=1;                   //找到增广路。
           
       }   
       printf("%d\n",sum);
    } 
    return 0;
} 
还是伟大的模板,搞了半天还不确定是不是明白了。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: