您的位置:首页 > 其它

poj_3041 Asteroids(匈牙利算法+最小点覆盖)

2016-10-23 14:16 405 查看
Asteroids

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 20834 Accepted: 11322
Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find
the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.
Input

* Line 1: Two integers N and K, separated by a single space. 

* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.
Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.
Sample Input
3 4
1 1
1 3
2 2
3 2

Sample Output
2

Hint

INPUT DETAILS: 

The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
X.X 

.X. 

.X. 

OUTPUT DETAILS: 

Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

把x轴和y轴看成二分图的x部和y部,这样直角坐标系上的点就可以当作二分图上的边。然后就是二分图的最小点覆盖的问题了。

根据König定理:最小覆盖点数==最大匹配数,所以就可以用匈牙利算法求最大匹配了。

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <stack>
#include <bitset>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <algorithm>
#define FOP freopen("data.txt","r",stdin)
#define inf 0x3f3f3f3f
#define maxn 505
#define mod 1000000007
#define PI acos(-1.0)
#define LL long long
using namespace std;

int edge[maxn][maxn];
bool used[maxn];
int linker[maxn];

int n, k;

bool dfs(int a)
{
for(int b = 1; b <= n; b++)
{
if(edge[a][b] && !used[b])
{
used[b] = true;
if(!linker[b] || dfs(linker[b]))
{
linker[b] = a;
return true;
}
}
}
return false;
}

int hun()
{
memset(linker, 0, sizeof(linker));
int res = 0;
for(int a = 1; a <= n; a++)
{
memset(used, false, sizeof(used));
if(dfs(a)) res++;
}
return res;
}

int main()
{
while(~scanf("%d%d", &n, &k))
{
memset(edge, 0, sizeof(edge));
int a, b;
for(int i = 1; i <= k; i++)
{
scanf("%d%d", &a, &b);
edge[a][b] = 1;
}
printf("%d\n", hun());
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: