您的位置:首页 > 产品设计 > UI/UE

POJ 2478 Farey Sequence 解题报告(欧拉函数 筛求法)

2014-04-22 09:17 357 查看
Farey Sequence

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11555 Accepted: 4492
Description

The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are 

F2 = {1/2} 

F3 = {1/3, 1/2, 2/3} 

F4 = {1/4, 1/3, 1/2, 2/3, 3/4} 

F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5} 

You task is to calculate the number of terms in the Farey sequence Fn.

Input

There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 106). There are no blank lines between cases. A line with a single 0 terminates the input.

Output

For each test case, you should output one line, which contains N(n) ---- the number of terms in the Farey sequence Fn. 

Sample Input
2
3
4
5
0


Sample Output
1
3
5
9


    解题报告: 用类似于素数筛的求法求欧拉函数。代码如下:
#include <cmath>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

const int maxn=1000010;
bool h[maxn];
int epi[maxn];
long long sum[maxn];

void calEpi()
{
for(int i=2;i<maxn;i++)
{
if(!h[i]) for(int j=i;j<maxn;j+=i)
{
if(epi[j]==0) epi[j]=j;
epi[j]=epi[j]/i*(i-1);
h[j]=true;
}

sum[i]=sum[i-1]+epi[i];
}
}

int main()
{
calEpi();

int n;
while(~scanf("%d", &n) && n)
{
printf("%lld\n", sum
);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  欧拉函数