您的位置:首页 > 其它

ZJU_PAT BASIC LEVEL _ 1019 数字的分解与排序

2014-02-22 09:44 411 查看


1019. 数字黑洞 (20)

时间限制

100 ms

内存限制

32000 kB

代码长度限制

8000 B

判题程序

Standard

作者

CHEN, Yue

给定任一个各位数字不完全相同的4位正整数,如果我们先把4个数字按非递增排序,再按非递减排序,然后用第1个数字减第2个数字,将得到一个新的数字。一直重复这样做,我们很快会停在有“数字黑洞”之称的6174,这个神奇的数字也叫Kaprekar常数。

例如,我们从6767开始,将得到

7766 - 6677 = 1089

9810 - 0189 = 9621

9621 - 1269 = 8352

8532 - 2358 = 6174

7641 - 1467 = 6174

... ...

现给定任意4位正整数,请编写程序演示到达黑洞的过程。

输入格式:

输入给出一个(0, 10000)区间内的正整数N。

输出格式:

如果N的4位数字全相等,则在一行内输出“N - N = 0000”;否则将计算的每一步在一行内输出,直到6174作为差出现,输出格式见样例。注意每个数字按4位数格式输出。
输入样例1:
6767

输出样例1:
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

输入样例2:
2222

输出样例2:
2222 - 2222 = 0000

/*******************************************88

@ Author	: GaominQuan
@ Data	: 2014-1-22
@ Mail	: ensoleilly@gmail.com

********************************************/

#include<iostream>
#include<vector>
#include<algorithm>
#include<math.h>
#include<functional>
using namespace std;
vector<int> changeToBits(int num){
vector<int> bits(4,0);
// NEED NOTICE HERE !!!!
int index = 0;
while(num>0){
int tail = num%10;
bits[in
4000
dex++] = tail;
num /= 10;
}

return bits;
}

void printVec(vector<int> vec){
for(int i = 0; i<vec.size(); i++){
cout<<vec[i];
}
}
vector<int> caculateOnce(vector<int> bits){
vector<int> greaterVec(bits);
sort(greaterVec.begin(),greaterVec.end(),greater<int>());

vector<int> lessVec(bits);
sort(lessVec.begin(), lessVec.end(), less<int>());

vector<int> ans(4);
vector<int> greaterVecCopy(greaterVec);
for(int i3 = bits.size()-1; i3>=0; i3--){

if(greaterVec[i3]<lessVec[i3]){
greaterVec[i3] += 10;
greaterVec[i3-1] -= 1;
}

int temp = greaterVec[i3] - lessVec[i3];
ans[i3] = temp;
}

printVec(greaterVecCopy);
cout<<" - ";
printVec(lessVec);
cout<<" = ";
printVec(ans);
cout<<endl;

return ans;
}

bool end(vector<int> ans){
bool needEnd;
if(ans[0] == ans[1] && ans[1] == ans[2] && ans[2] == ans[3] && ans[3] == 0){
needEnd =  true;
}else if(ans[0] == 6 && ans[1] == 1 && ans[2] == 7 && ans[3] == 4){
needEnd =  true;
}else{
needEnd =  false;
}
return needEnd;
}

int main(){
int num = 6767;
cin>>num;

vector<int> bits = changeToBits(num);

vector<int> ans = caculateOnce(bits);
while(end(ans) == false){
ans = caculateOnce(ans);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ZJU OJ