您的位置:首页 > 编程语言 > C语言/C++

EASY_PAT_ADVANCED LEVEL 1008_简单的面向对象 队列的使用

2014-02-23 10:19 459 查看
NOTE:

1. class 的时候,利用this指针会让程序明了很多;

2. vector的erase和resize与Java里边的remove和resize并不一样,以后还要进一步研究一下;

3. 正确的利用STL,会让程序更加明了。





1008. Elevator (20)

时间限制

400 ms

内存限制

32000 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to
move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.
Sample Input:
3 2 3 1

Sample Output:
41


/***********************************************

@ Date	: 2014 - 2 - 23
@ Author	: GAOMINQAUN
@ Mail	: ensoleilly@gmail.com
@	Name	: PAT_ADVANCED_LEVEL_1008

***********************************************/
#include<iostream>
#include<queue>
using namespace std;
enum direction{up,down,initPlace};
class elevator{
public:
int upTime;
int downTime;
int eachStopTime;
int currentFloor;
int totalTime;
int targetFloor;
queue<int> taskList;
elevator():upTime(6),downTime(4),eachStopTime(5),currentFloor(0),totalTime(0),targetFloor(0){}

void setTaskList(int N){
for(int tIndex = 0; tIndex < N; tIndex++){
int temp;
cin>>temp;
this->taskList.push(temp);
}
}

direction whereToGo(){
//cout<<"whereToGo,List Length"<<endl;
//cout<<taskList.size()<<endl;
direction dt = initPlace;
if(!taskList.empty()){
this->targetFloor = taskList.front();
taskList.pop();
if(this->targetFloor >this-> currentFloor){
dt = up;
}else{
dt = down;
}
//cout<<taskList.size
4000
();
}else{
dt = initPlace;
this->targetFloor = 0;
}
//cout<<"targetFloor"<<this->targetFloor<<endl;
//cout<<" dt == "<<dt<<endl;
return dt;
};

bool move(){ // return true to continue move, false to end move
direction dt = this->whereToGo();
bool goOnMove = false;
int moveTime = 0;
switch(dt){
case up:
moveTime = this->upTime;
//this->totaltime = moveTime + this->eachStopTime;
break;
case down:
moveTime = this->downTime;
break;
case initPlace:
this->targetFloor = 0;
int moveTime = this->downTime;
}

this->totalTime += moveTime*abs(this->targetFloor - this->currentFloor);

if(dt != initPlace){
this->totalTime += this->eachStopTime;
goOnMove = true;
}else{
goOnMove = false;
}

this->currentFloor = this->targetFloor;

return goOnMove;
};

int getCurrentFloor(){
return this->currentFloor;
}
int getTotalTime(){
return this->totalTime;
}
};
int main(){
elevator elt;
int N = 0;
cin>>N;

elt.setTaskList(N);
while(elt.move());
cout<<elt.getTotalTime();

return 0;
}


                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  OJ C++