您的位置:首页 > 其它

寒假训练--KMP--Period

2014-02-11 15:20 239 查看

Period

Time Limit: 1000MS Memory limit: 65536K

题目描述

For each prefix of a given string S with N characters (each character has an
ASCII code between 97 and 126, inclusive), we want to know whether the prefix
is a periodic string. That is, for each i (2 ≤ i ≤ N) we want to know the largest K
> 1 (if there is one) such that the prefix of S with length i can be written as AK ,
that is A concatenated K times, for some string A. Of course, we also want to
know the period K.
 

输入

 The input file consists of several test cases. Each test case consists of two
lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.
The second line contains the string S. The input file ends with a line, having the
number zero on it.
 

输出

 For each test case, output “Test case #” and the consecutive test case
number on a single line; then, for each prefix with length i that has a period K >
1, output the prefix size i and the period K separated by a single space; the
prefix sizes must be in increasing order. Print a blank line after each test case.
 

示例输入

3
aaa
12
aabaabaabaab
0


示例输出

Test case #1
2 2
3 3
Test case #2
2 2
6 2
9 3
12 4


提示

 

来源

 Southeastern European Regional Programming Contest
与power strings相同,计算一个字符串内的循环串的个数

 
 

示例程序

#include <stdio.h>
#include <stdlib.h>
char str[1000002] ;
int next[1000002] ;
void getnext(int l)
{
int j = 0 , k = -1 ;
next[0] = -1 ;
while(j < l)
{
if(k==-1 || str[j]== str[k])
{
j++; k++;
next[j] = k ;
}
else
k = next[k] ;
}
}
int main()
{
int i , j , l , ll ,count = 0 ;
while(scanf("%d", &l)&&l)
{
scanf("%s", str);
count++;
getnext(l);
printf("Test case #%d\n", count);
for(j = 2 ; j <= l ; j++)
{
ll = j - next[j] ;
if(j % ll == 0 && j/ll != 1)
printf("%d %d\n", j, j/ll);
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: