您的位置:首页 > 其它

HDU-1358 Period(kmp专题)

2016-07-27 11:43 387 查看
E - Period
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Submit Status Practice HDU
1358

Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the
largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K , that is A concatenated K times, for some string A. Of course, we also want to know the period K. 

 

Input

The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line,
having the number zero on it. 

 

Output

For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the
prefix sizes must be in increasing order. Print a blank line after each test case. 

 

Sample Input

3
aaa
12
aabaabaabaab
0

 

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

 

求前缀周期,kmp的简单应用

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<limits.h>
#include<math.h>
#include<algorithm>
using namespace std;
int n,m,k,cases=0;
char a[1000005];
int p[1000005];
void print()
{
int i,j=0;
p[1]=0;
for(i=2;i<=n;i++)
{
while(j>0 && a[i]!=a[j+1])
j=p[j];
if(a[j+1]==a[i])
j++;
p[i]=j;
}
printf("Test case #%d\n",++cases);
int x;
for(i=1;i<=n;i++)
{
x=i%(i-p[i]);
if(x==0 && p[i]>=1)
printf("%d %d\n",i,i/(i-p[i]));
}
puts("");
}
int  main()
{
int i,j;
while(scanf("%d",&n),n!=0)
{
k=0;
scanf(" %s",a+1);
print();
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: