您的位置:首页 > 移动开发

POJ 2773 Happy 2006 欧拉函数

2014-02-09 10:47 477 查看
点击打开链接

Happy 2006

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 8940 Accepted: 2983
Description

Two positive integers are said to be relatively prime to each other if the Great Common Divisor (GCD) is 1. For instance, 1, 3, 5, 7, 9...are all relatively prime to 2006. 

Now your job is easy: for the given integer m, find the K-th element which is relatively prime to m when these elements are sorted in ascending order. 

Input

The input contains multiple test cases. For each test case, it contains two integers m (1 <= m <= 1000000), K (1 <= K <= 100000000).
Output

Output the K-th element in a single line.
Sample Input
2006 1
2006 2
2006 3

Sample Output
1
3
5

Source

POJ Monthly--2006.03.26,static

给你m和k,求第k个与m互质的数。
在1~m之间有phi[m](phi[m]是m的欧拉函数)个数与m互质,而在m+1~2*m之间也有phi[m]个数与m互质,且在n*m+1~(n+1)*m之间也有phi[m]个数与m互质,并且这phi[m]个数与在1~m之间的phi[m]个数是相互对应的。
因此只要求出第k/phi[m]个区间,然后在这个区间枚举第k个数就可以。当然此方法的时间复杂度不是很优化,不过比较易懂。
//4300K	1594MS
#include<stdio.h>
#include<string.h>
#define M 1000007
int phi[M];
void getphi()//得到欧拉函数
{
memset(phi,0,sizeof(phi));
phi[1]=1;
for(int i=2;i<M;i++)
{
if(!phi[i])
for(int j=i;j<M;j+=i)
{
if(!phi[j])
phi[j]=j;
phi[j]=phi[j]/i*(i-1);
}
}
}
int gcd(int a,int b)
{
if(!b)return a;
return gcd(b,a%b);
}
int main()
{
int m,k;
getphi();
while(scanf("%d%d",&m,&k)!=EOF)
{
int num=k/phi[m];
if(k%phi[m]==0)num--;
k=k-num*phi[m];//在第num个区间求第k个
num=num*m+1;//求在第num个区间的第一个数
int flag;
for(int i=num;k!=0;i++)//枚举求第k个与m互质的数
if(gcd(i,m)==1)
{
flag=i;
k--;
}
printf("%d\n",flag);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: