您的位置:首页 > 其它

【PAT】1065. A+B and C (64bit) (20)

2013-11-01 15:15 351 查看
Given three integers A, B and C in [-263, 263], you are supposed to tell whether A+B > C.

Input Specification:

The first line of the input gives the positive number of test cases, T (<=10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line "Case #X: true" if A+B>C, or "Case #X: false" otherwise, where X is the case number (starting from 1).

Sample Input:
3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:
Case #1: false
Case #2: true
Case #3: false


分析:要考虑相加溢出的情况

(1)  a > 0 && b>0 && a+b <0  , 则 a+b > c

(2)  a < 0 && b<0 && a+b >0 , 则 a+b<c

此外,vc++6.0不支持long long型数据,而PAT上又不支持 __int64数据,所以最后选择用vs,采用long long 数据。

#include<iostream>
using namespace std;

int main()
{
long long a,b,c,temp;
int t,i;
bool flag;
scanf("%d",&t);
for( i=1; i<=t; i++)
{
flag = true;
scanf("%lld%lld%lld",&a,&b,&c);
printf("Case #%d: ",i);
temp = a+b;
if(a>0 && b>0 && temp<=0){
flag = true;
}else if(a<0 && b<0 && temp>=0){
flag = false;
}else flag = temp > c;

if(!flag)
printf("false\n");
else
printf("true\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  PAT