您的位置:首页 > 其它

zoj 2110 Tempter of the Bone(DFS+奇偶剪枝及优化操作)

2013-10-21 21:25 375 查看
1、http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=1110

2、题目大意:

Tempter of the Bone

Time Limit: 2 Seconds Memory Limit:
65536 KB

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out
of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly
the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one
block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give
the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;

'S': the start point of the doggie;

'D': the Door; or

'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.

Output

For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.

Sample Input

4 4 5

S.X.

..X.

..XD

....

3 4 5

S.X.

..X.

...D

0 0 0



Sample Output


NO

YES

2、AC代码:

#include<stdio.h>
#include<math.h>
char map[9][9];
int n,m,sx,sy,ex,ey,t;
int dir[4][2]={1,0,-1,0,0,-1,0,1};
int flag;
void DFS(int ssx,int ssy,int cnt)
{
//此代码会导致返回的上一结点,不能通过flag=1直接返回
//    if(ssx==ex && ssy==ey && cnt==t)
//    {
//        flag=1;
//        return;
//    }

if(ssx==ex && ssy==ey && cnt==t)
flag=1;
if(flag)
return;
if(ssx<=0 || ssx>n || ssy<=0 || ssy>m)
return;
int tmp=t-cnt-fabs(ex-ssx)-fabs(ey-ssy);
if(tmp<0 || tmp%2!=0)//奇偶剪枝
return;
for(int i=0;i<4;i++)
{
int tx=ssx+dir[i][0];
int ty=ssy+dir[i][1];
if( map[tx][ty]!='X')
{
map[tx][ty]='X';
DFS(tx,ty,cnt+1);
map[tx][ty]='.';
}
}
return ;
}
int main()
{
while(scanf("%d%d%d",&n,&m,&t)!=EOF)
{
getchar();
int wall=0;
if(n==0 && m==0 && t==0)
break;
for(int i=1;i<=n;i++)
{
for(int j=1;j<=m;j++)
{
scanf("%c",&map[i][j]);
if(map[i][j]=='S')
{
sx=i;
sy=j;
}
else if(map[i][j]=='D')
{
ex=i;
ey=j;
}
else if(map[i][j]=='X')
wall++;
}
getchar();
}

if(n*m-wall<=t)//优化操作,如果能走的个数小,直接返回NO
printf("NO\n");
else
{
flag=0;
map[sx][sy]='X';
DFS(sx,sy,0);
if(flag)
printf("YES\n");
else
printf("NO\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: