您的位置:首页 > 其它

ZOJ 2110 Tempter of the Bone (DFS+减枝)

2013-02-04 15:12 211 查看
Tempter of the Bone

Time Limit: 2 Seconds
Memory Limit: 65536 KB

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this
maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the
T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for
more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the
maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;

'S': the start point of the doggie;

'D': the Door; or

'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.

Output

For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.

Sample Input

4 4 5

S.X.

..X.

..XD

....

3 4 5

S.X.

..X.

...D

0 0 0



Sample Output


NO

YES

思路:直接深搜所有可以从S到D的路径,如果有答案就马上返回。其中需要减枝,否则会超时。
t-tt-abs(x-ox)+abs(y-oy)<0 不行仍然超时

当t-tt-abs(x-ox)+abs(y-oy)<0或者是奇数都不行这样,680ms能过

再加上当n*m-x的数目<=t 160MS能过

#include<iostream>
#include<cstring>
using namespace std;
const int mm=11;
const int dx[]={1,-1,0,0};
const int dy[]={0,0,1,-1};
char grap[mm][mm];
bool vis[mm][mm];
int m,n,t,ox,oy;
int abs(int x)
{
return x>0?x:-x;
}
bool dfs(int x,int y,int tt)
{ int tx,ty;
if(grap[x][y]=='D'&&tt==t)return true;
int tmp=t-tt-abs(x-ox)-abs(y-oy);
if(tmp<0||tmp%2==1)return false;
for(int i=0;i<4;i++)
{
tx=x+dx[i];ty=y+dy[i];
if(tx>=0&&tx<m&&ty>=0&&ty<n&&!vis[tx][ty]&&grap[tx][ty]!='X')
{ vis[tx][ty]=1;
if(dfs(tx,ty,tt+1))return true;
vis[tx][ty]=0;
}
}
return false;
}
int main()
{
while(cin>>m>>n>>t)
{ int x,y;
if(m==0&&n==0&&t==0)break;
memset(vis,0,sizeof(vis));
int w=0;
for(int i=0;i<m;i++)
for(int j=0;j<n;j++)
{
cin>>grap[i][j];
if(grap[i][j]=='S')
x=i,y=j;
if(grap[i][j]=='D')
ox=i,oy=j;
if(grap[i][j]=='X')
w++;
}
if(n*m-w<=t){cout<<"NO\n";continue;}
vis[x][y]=1;
if(dfs(x,y,0))
cout<<"YES\n";
else cout<<"NO\n";
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: