您的位置:首页 > 其它

POJ-2352-Stars(树状数组)

2018-03-26 17:25 375 查看
Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it’s formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5

1 1

5 1

7 1

3 3

5 5

Sample Output

1

2

1

1

0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

题干有点不好翻译。

给出n个stars的坐标,对于当前的star,如果有k个 stars的横纵坐标均不大于此star的横纵坐标,那么这个star的等级就为k

输出的n行代表等级从0-n-1的star的个数。

思路:

首先要对输入的数据进行排序,x从小到大排,如果x相等,那么y就从小到大排序。

这样就不需要处理x坐标了,维护树状数组的时候只需要对y进行维护。

树状数组维护的值:对于当前的star,前面的y比它小的star的个数。

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<cmath>
#include<iomanip>
#include<map>
#include<stack>
#include<vector>
#include<queue>
#include<algorithm>
#define max(a,b)   (a>b?a:b)
#define min(a,b)   (a<b?a:b)
#define swap(a,b)  (a=a+b,b=a-b,a=a-b)
#define memset(a)  memset(a,0,sizeof(a))
#define X (sqrt(5)+1)/2.0  //Wythoff
#define Pi acos(-1)
#define e  2.718281828459045
using namespace std;
typedef long long int LL;
const int MAXL(15000);
const int INF(0x3f3f3f3f);
const int mod(1e9+7);
int dir[4][2]= {{-1,0},{1,0},{0,1},{0,-1}};
struct node
{
int x,y;
}s[MAXL+50];
int ans[MAXL+50];
int c[32000+50];
int maxY;
bool cmp(struct node p,struct node q)
{
if(p.x==q.x)
return p.y<q.y;
return p.x<q.x;
}
int lowbit(int k)
{
return k&(-k);
}
void Update(int i,int v)
{
while(i<=maxY)
c[i]+=v,i+=lowbit(i);
}
int Getsum(int i)
{
int ans=0;
while(i>0)
ans+=c[i],i-=lowbit(i);
return ans;
}
int main()
{
memset(c);
int n;
scanf("%d",&n);
for(int i=0;i<n;i++)
{
scanf("%d%d",&s[i].x,&s[i].y);
s[i].x++,s[i].y++;
maxY=max(maxY,s[i].y);
}
sort(s,s+n,cmp);
for(int i=0;i<n;i++)
{
Update(s[i].y,1);
int temp=Getsum(s[i].y);
ans[temp-1]++;
}
for(int i=0;i<n;i++)
cout<<ans[i]<<endl;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: