您的位置:首页 > 其它

POJ 2352 Stars(树状数组)

2016-05-13 15:49 441 查看
F - Stars
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d
& %I64u
Submit Status

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know
the distribution of the levels of the stars. 



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level
0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars
are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5


Sample Output

1
2
1
1
0


Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.


题解:

仔细想下,这题的y没有用,有用的只是x,x出现一次就加一次(这里是x+1,因为x可能等于0),之后再把0到x的全部值加一遍,得出的tem用ans数组记录下来,最后输出即可。

AC代码:

#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

const int MAX_N=15005;
const int MAX_B=15005<<2;//范围尽量开大  4倍 也就是和线段树一样

int bit[MAX_B],n;
int ans[MAX_N];

int sum(int i)//相加是减到最根节点
{
    int s=0;
    while(i>0)
    {
        s+=bit[i];
        i-=i&-i;
    }
    return s;
}
void add(int i,int x)//修改是不断向父节点延伸
{
    while(i<=MAX_B)/**< 最重要的就是这!! 这是i<=MAXB  而不是n!! */
    {
        bit[i]+=x;
        i+=i&-i;
    }
}
int main()
{
    while(scanf("%d",&n)!=EOF)///输入全用scan = =用cin的我超了好几次时
    {
        memset(ans,0,sizeof(ans));
        memset(bit,0,sizeof(bit));
        int x,y;
        for (int i=1;i<=n;i++)
        {
            scanf("%d%d",&x,&y);
            int tem=sum(x+1);
            ans[tem]++;
            add(x+1,1);
        }
        for (int i=0;i<n;i++)
        {
            printf("%d\n",ans[i]);
        }
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  BIT树状数组 POJ ACM