您的位置:首页 > 其它

hdu 1241 Oil Deposits

2013-07-15 20:49 441 查看


Oil Deposits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 7654    Accepted Submission(s): 4473


Problem Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each
plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous
pockets. Your job is to determine how many different oil deposits are contained in a grid. 

 

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following
this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

 

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

 

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

 

Sample Output

0
1
2
2

 

Source

Mid-Central USA 1997

难道这是个卡输入的题目,刚刚按照scanf输入始终找不到最后一列数据,很纠结什么样的原因,而用cin,输入则得到正确答案,另外听别人说是因为5 5后面多了个空格,但是自己也尝试了,找不到原因,纠结,以后有机会补上。。
代码:
#include<iostream>
using namespace std;
char mp[102][102];
int m,n;
int dir[8][2]={1,1,1,-1,1,0,-1,0,-1,-1,-1,1,0,1,0,-1};
void dfs(int x,int y)
{
for(int i=0;i<8;i++)
{
int xx=dir[i][0]+x;
int yy=dir[i][1]+y;
if(xx>=0&&xx<m&&yy>=0&&yy<n&&mp[xx][yy]=='@')
{
mp[xx][yy]='*';
dfs(xx,yy);
}
}
}
int main()
{
int cnt=0;
while(cin>>m>>n)
{
cnt=0;
if(!(m+n))
break;
for(int i=0;i<m;i++)
cin>>mp[i];
for(int i=0;i<m;i++)
for(int j=0;j<n;j++)
{
if(mp[i][j]=='@')
{
mp[i][j]='*';
cnt++;
dfs(i,j);
}
}
printf("%d\n",cnt);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  hdu 1241 Oil Deposits