您的位置:首页 > 其它

HDU--1241 -- Oil Deposits [水水的DFS]

2013-08-07 16:00 531 查看
 

Oil Deposits

 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 8176    Accepted Submission(s): 4791

Problem Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots.
It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large
and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

 
Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100
and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

 
Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

 
Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

 Sample Output

0
1
2
2

 

Code:

 

这一题跟1312  red and black 基本一样, 只多了条件而已,~ 水了

Compilation Error ! Compilation Error ! CE ! CE ! 让我细心点吧...


要在循环开始前定义变量, 不要急啊不要急啊, 我的正确率啊...55555

 

#include"stdio.h"
#include"string.h"
int sign[110][110];
int x,y;
void dfs(int m,int n)
{
sign[m]
= 1;
if(!sign[m][n+1] && n+1<y) dfs(m,n+1);
if(!sign[m+1][n+1] && m+1<x&&n+1<y) dfs(m+1,n+1);
if(!sign[m+1]
&& m+1<x) dfs(m+1,n);
if(!sign[m+1][n-1] && m+1<x && n-1>-1) dfs(m+1,n-1);
if(!sign[m][n-1] && n-1>-1) dfs(m,n-1);
if(!sign[m-1][n-1] && m-1>-1 && n-1>-1) dfs(m-1,n-1);
if(!sign[m-1]
&& m-1>-1) dfs(m-1,n);
if(!sign[m-1][n+1] && m-1>-1 && n+1<y) dfs(m-1,n+1);
}

int main()
{
int i,j,count=0;
char str[110];
while(scanf("%d%d",&x,&y),x)
{
memset(sign,0,sizeof(sign));
count = 0;
for(i=0;i<x;i++)
{
scanf("%s",str);
for(j=0;j<y;j++)
{if(str[j] == '*') sign[i][j] = 1;}
}

//	for(i=0;i<x;i++)
//		{
//			for(j=0;j<y;j++)
//				printf("%d ",sign[i][j]);
//			printf("\n");
//		}

for(i=0;i<x;i++)
{
for(j=0;j<y;j++)
{
if(!sign[i][j])
{
dfs(i,j);
count++;
}
}
}
printf("%d\n",count);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: