您的位置:首页 > 其它

HDU 1198 Farm Irrigation(并查集)

2013-07-17 19:18 417 查看


Farm Irrigation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 3968    Accepted Submission(s): 1733


Problem Description

Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked from A
to K, as Figure 1 shows.



Figure 1

Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map 

ADC

FJK

IHE

then the water pipes are distributed like 



Figure 2

Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn. 

Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him? 

Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show.

 

Input

There are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of 'A' to 'K', denoting the type of water pipe over the corresponding square. A negative
M or N denotes the end of input, else you can assume 1 <= M, N <= 50.

 

Output

For each test case, output in one line the least number of wellsprings needed.

 

Sample Input

2 2
DK
HF

3 3
ADC
FJK
IHE

-1 -1

 

Sample Output

2
3

 

Author

ZHENG, Lu

 

Source

Zhejiang University Local Contest 2005

 

Recommend

Ignatius.L

解题思路:算是第一个比较认真的,认真钻研的一道并查集的题目,并查集在图论算法中往往可以优化算法。
另外记录每一个图的时候要注意它们的顺序,前几次提交就是因为顺序搞混了,这次的顺序是上下左右一次找

并查集顾名思义是 并和查

合并两个不相交集合

操作很简单:先设置一个数组Father[x],表示x的“父亲”的编号。 那么,合并两个不相交集合的方法就是,找到其中一个集合最父亲的父亲(也就是最久远的祖先),将另外一个集合的最久远的祖先的父亲指向它。

代码:

void Union(int x,int y)
{
fx = getfather(x);
fy = getfather(y);
if(fy!=fx)
father[fx]=fy;
}
查是否有公共的祖先

int find(int x)
{
while(set[x]!=x)
x=set[x];
return x;
}


代码:
#include<cstdio>
#include<cstring>
using namespace std;
int n,m,sum,set[3600];
char mp[60][60];
int path[11][4]={{1,0,1,0}, {1,0,0,1}, {0,1,1,0}, {0,1,0,1}, {1,1,0,0}, {0,0,1,1}, {1,0,1,1}, {1,1,1,0}, {0,1,1,1}, {1,1,0,1}, {1,1,1,1}};

int find(int x) { while(set[x]!=x) x=set[x]; return x; }

int merge(int x,int y)
{
x=find(x);
y=find(y);
if(x==y) return 0;
set[x]=y;
return 1;
}

void search(int x,int y)
{
if(x>0 && path[mp[x][y]-'A'][0] && path[mp[x-1][y]-'A'][1])
sum-=merge(x*m+y,(x-1)*m+y);
if(y>0 && path[mp[x][y]-'A'][2] && path[mp[x][y-1]-'A'][3])
sum-=merge(x*m+y,x*m+y-1);
}

int main()
{
while(scanf("%d %d",&n,&m)!=EO
4000
F)
{
if(n==-1 && m==-1)
break;
for(int i=0;i<3600;i++)
set[i]=i;
for(int i=0;i<n;i++)
scanf("%s",mp[i]);
sum=n*m;
for(int i=0;i<n;i++)
for(int j=0;j<m;j++)
{
search(i,j);
}
printf("%d\n",sum);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息