您的位置:首页 > 其它

2013 - ECJTU 暑期训练赛第二场-problem-J

2013-07-15 20:33 302 查看
J -
J
Crawling in process...
Crawling failed
Time Limit:1000MS    
Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Submit

Status
Practice
HDU 1241

Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates
a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are
part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

 

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m =
0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of
oil, or `@', representing an oil pocket.

 

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally.
An oil deposit will not contain more than 100 pockets.

 

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

 

Sample Output

0
1
2
2深度搜索(DFS)问题题目大概意思是:搜索油田,如果油田靠在一起就算一种油田,只有没有靠在一起才算另一种油田,什么才算靠着:上下左右,左斜上,左斜下,右斜上,右斜下八个方位如果连着就算靠着AC代码:#include<iostream>
const int MAX=101;
char s[MAX][MAX];
using namespace std;
int main()
{
int n,m,i,j,sum;
void Sousuo(int x,int y,int m,int n);
while(cin>>m>>n&&(m))
{
memset(s,0,sizeof(s));
getchar();
for(i=1;i<=m;i++)
{
for(j=1;j<=n;j++)
{
cin>>s[i][j];
}
getchar();
}
sum=0;
for(i=1;i<=m;i++)
{
for(j=1;j<=n;j++)
{
if(s[i][j]=='@')
{
sum+=1;
Sousuo(i,j,m,n);
}
}
}
cout<<sum<<endl;
}
return 0;
}
void Sousuo(int x,int y,int m,int n)
{
    if(x>=1&&x<=m&&y>=1&&y<=n)
    {
      if(s[x][y]=='@')  
      {
        s[x][y]='*'; 
        Sousuo(x-1,y-1,m,n);//八个方位搜索
        Sousuo(x-1,y,m,n);
        Sousuo(x-1,y+1,m,n);
        Sousuo(x,y-1,m,n);
        Sousuo(x,y+1,m,n);
        Sousuo(x+1,y-1,m,n);
        Sousuo(x+1,y,m,n);
        Sousuo(x+1,y+1,m,n);
      }
    }
}                                    
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息