您的位置:首页 > 其它

2013 - ECJTU 暑期训练赛第二场-problem-G

2013-07-15 20:25 459 查看
G -
G
Crawling in process...
Crawling failed
Time Limit:1000MS    
Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Submit

Status
Practice
HDU 2602

Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the
grave …

The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the
maximum of the total value the bone collector can get ?



 

Input

The first line contain a integer T , the number of cases.

Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third
line contain N integers representing the volume of each bone.
 

Output

One integer per line representing the maximum of the total value (this number will be less than 231).
 

Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1

 

Sample Output

1401背包问题,简单DP问题AC代码:#include<iostream>
#include<cmath>
const int MAX=1001;
int beibao[MAX];
int jiazhi[MAX];
int tiji[MAX];
using namespace std;
int main()
{
    int i,j,n,v,T;
    cin>>T;
    while(T--)
    {
      cin>>n>>v;
      memset(beibao,0,sizeof(beibao));
      for(i=1;i<=n;i++)
      cin>>tiji[i];
      for(i=1;i<=n;i++)
      cin>>jiazhi[i];
      for(i=1;i<=n;i++)
      {
        for(j=v;j>=tiji[i];j--)
        {
         
            beibao[j]=max(beibao[j],beibao[j-tiji[i]]+jiazhi[i]);
            //cout<<beibao[j]<<" ";
        }
        cout<<endl;
      }
      cout<<beibao[v]<<endl;
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息