您的位置:首页 > 运维架构

POJ-3258 River Hopscotch 解题报告(二分) 牛跳石头

2012-04-09 19:40 375 查看
链接- H -River
Hopscotch

Time Limit:2000MS Memory Limit:65536KB 64bit IO Format:%I64d
& %I64u


Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end,L
units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks,N (0 ≤N ≤ 50,000) more rocks appear, each at an integral distanceDi from the start (0 <Di
< L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in
order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up toMrocks (0 ≤M ≤N).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set ofM rocks.

Input

Line 1: Three space-separated integers: L,N, andM

Lines 2..N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removingM rocks

Sample Input

25 5 2
2
14
11
21
17


Sample Output

4


Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).

题目大意:牛跳石头,河中有很多石头,移去M颗,使剩下石头两两距离的最小距最大。

#include<cstdio>
#include<algorithm>
using namespace std;
int	dis[50000+5];
int l,n,m;
int move(int mid)
{
	int pre=0,sum=0,i;
	for(i=1;i<n+2;i++)
	{
		if(dis[i]-dis[pre]<mid)
			sum++;
		else
			pre=i;
	}
	return sum;
}

int main()
{
	scanf("%d%d%d",&l,&n,&m);
	int i,ans;
	for(i=1;i<n+1;i++)
		scanf("%d",&dis[i]);
	dis[0]=0;dis[n+1]=l;
	sort(dis,dis+n+1);
	int left=0,right=l,mid;
	while(right-left>=0)
	{
		mid=(right-left)/2+left;
		if(move(mid)<=m)
			{left=mid+1;ans=mid;}
		else
			right=mid-1;
	}
	printf("%d\n",ans);
	return 0;
}


答案解析:看懂move函数就好办了。
设定一个最大距,看两两石头距离中有几个比这个距离小,若总数sum<=M,则增大设定值继续二分,否则减小设定值,继续二分。直到区间长度变为0,则跳出。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: