您的位置:首页 > 运维架构

POJ-3258 River Hopscotch 解题报告

2012-03-16 18:19 344 查看
Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with
a rock at the start and another rock at the end, L units away from the start (1 ≤
L ≤ 1,000,000,000). Along the river between the starting and ending rocks,
N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance
Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final
rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed
too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up
to M rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance
*before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of
M rocks.

Input

Line 1: Three space-separated integers:
L, N, and M

Lines 2..N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing
M rocks

Sample Input

25 5 2

2

14

11

21

17


Sample Output

4

题目大意:题目很长哈,简单来说,数轴上有n个石子,第i个石头的坐标为Di,现在要从0跳到L,每次条都从一个石子跳到相邻的下一个石子。现在FJ允许你移走M个石子,问移走这M个石子后,相邻两个石子距离的最小值的最大值是多少,因为移动有很多种方法,每一种有一个最小值距离,这些最小值里面的最大值(我之所以解释最后一句,是因为我兄弟他没懂--其实不是我翻译的,嘿嘿)。

题目链接:http://poj.org/problem?id=3258

方法:二分法

思路:在这里二分的对象当然是距离咯,我主要说下判断的条件,当你已经模拟了一个距离值后,你需要对原有的石子进行移动,因为你模拟的最小间距,所以如果两个相邻石子距离比他小,那么就应该移除后一个石子(为什么移除后一个,你可以模拟开始两石子就不满足的话,不可能移除起点吧),记录移除石子加一,然后进行下次计算,直到有个点和开始的这个点距离大于最小值(开始的点不一定是起点),记得此时更改起始点为满足时的后一个点(如不懂,可以再草稿上模拟一下过程),进行下次比较,最后比较移除的石子和实际的比较,在改变高低点的位置。

算法实现:

#include<stdio.h>
#include<iostream>
#include<algorithm>
using namespace std;
#define MAX 50008
int main()
{
int L,N,M;
int a[MAX];
int i,sum,point;
int low,high,mid,step;
while(scanf("%d%d%d",&L,&N,&M)!=EOF)
{
for(i=0;i<N;i++)
scanf("%d",&a[i+1]);
sort(a+1,a+N+1);
a[0]=0;
a[N+1]=L;
low=0;
high=L;
while(high-low>=0)
{
sum=0;
mid=(low+high)/2;
point=0;//用来记录此时起始节点的候选情况。
for(i=1;i<=N+1;i++)
{
if(a[i]-a[point]<mid)//如果相邻两节点的距离小于此时的假设最小值,则删除该节点,记录加一。
sum++;//记录移动石子的数目。
else//否则则更换起始节点的候选情况为节点a[i].
point=i;
}
if(sum>M)
high=mid-1;
else
{
low=mid+1;
step=mid;//满足一次则记录一次。
}
}
printf("%d\n",step);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: