您的位置:首页 > 运维架构

POJ-3258 River Hopscotch 解题报告

2012-03-16 01:25 429 查看
Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units
away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di <L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in
order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to M rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers: L, N, and M

Lines 2..N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks

Sample Input
25 5 2

2

14

11

21

17

Sample Output
4

Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).

题目链接:http://poj.org/problem?id=3258

解法类型:二分

解题思路:话说这题让我对二分法有了新的认识。注意其中的函数关系,两石头间的最小距离和移动的石头数之间是单调递增函数,所以就可以对距离二分了,效率很高的。

算法实现:
//STATUS:C++_AC_125MS_316K
#include<stdio.h>
#include<stdlib.h>
const int MAX=50010;
int cmp_num(const void *a,const void *b);
int d[MAX];
int main()
{
//	freopen("in.txt","r",stdin);
	int L,N,M,i,low,mid,high,tot,a,b;
	while(~scanf("%d%d%d",&L,&N,&M))
	{
        low=-1,high=L+1,mid=L;
		for(i=0;i<N;i++)
			scanf("%d",&d[i]);
		
		qsort(d,N,sizeof(int),cmp_num);   //快速排序

		if(N && N>M)   //注意N=0和N<=M的情况
			for(mid=(low+high)/2;high-low!=1;mid=(low+high)/2){
				for(i=0,a=0,b=d[0],tot=0;i<N;a=b,b=d[++i]){
					while(b-a<mid && i<N){       //石头距离累加,知道大于mid;
						tot++;
						b=d[++i];
					}
					if(i==N-1){if(L-d[N-1]<mid)tot++; break;}   //要考虑最后一个石头不能搬动
					if(i==N){if(L-a<mid)tot++; break;}
				}
       
	           	if(tot<=M)low=mid;
	        	else high=mid;
			}
		printf("%d\n",mid);
	}
	return 0;
}

int cmp_num(const void *a,const void *b)   //快速排序
{
	return *(int*)a - *(int*)b;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: