您的位置:首页 > 其它

POJ 3090 Visible Lattice Points 欧拉函数

2011-02-07 20:02 513 查看
http://poj.org/problem?id=3090

Visible Lattice Points

Time Limit: 1000MSMemory Limit: 65536K
Description

A lattice point (x, y) in the first quadrant (x and y are integers greater than or equal to 0), other than the origin, is visible from the origin if the line from (0, 0) to (x, y) does not pass through any other lattice point. For example, the point (4, 2) is not visible since the line from the origin passes through (2, 1). The figure below shows the points (x, y) with 0 ≤ x, y ≤ 5 with lines from the origin to the visible points.



Write a program which, given a value for the size, N, computes the number of visible points (x, y) with 0 ≤ x, yN.

Input

The first line of input contains a single integer C (1 ≤ C ≤ 1000) which is the number of datasets that follow.

Each dataset consists of a single line of input containing a single integer N (1 ≤ N ≤ 1000), which is the size.

Output

For each dataset, there is to be one line of output consisting of: the dataset number starting at 1, a single space, the size, a single space and the number of visible points for that size.

Sample Input

4
2
4
5
231

Sample Output

1 2 5
2 4 13
3 5 21
4 231 32549

牛人做法:

先画一条(0, 0)到(n, n)的线,把图分成两部分,两部分是对称的,只需算一部分就好。
取右下半,这一半里的点(x, y)满足x >= y
可以通过欧拉函数计算第k列有多少点能够连到(0, 0)
若x与k的最大公约数d > 1,则(0, 0)与(x, k)点的连线必定会通过(x/d, k/d),就被挡住了
所以能连的线的数目就是比k小的、和k互质的数的个数,然后就是欧拉函数。

/* Author : yan
* Question : POJ 3090 Visible Lattice Points
* Date && Time : Wednesday, January 12 2011 12:01 AM
* Compiler : gcc (Ubuntu 4.4.3-4ubuntu5) 4.4.3
*/
#include<stdio.h>
unsigned euler(unsigned x)
{// 就是公式
unsigned i, res=x,tmp;
tmp= (int)sqrt(x * 1.0) + 1;
for (i = 2; i <tmp; i++)
if(x%i==0)
{
res = res / i * (i - 1);
while (x % i == 0) x /= i; // 保证i一定是素数
}
if (x > 1) res = res / x * (x - 1);
return res;
}

int main()
{
freopen("input","r",stdin);
int test;
int n;
int i;
int ans;
int _case=1;
scanf("%d",&test);
while(test--)
{
ans=0;
scanf("%d",&n);
for(i=2;i<=n;i++)
{
ans+=euler(i);
}
printf("%d %d %d/n",_case++,n,ans*2+3);
}
return 0;
}
[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: