您的位置:首页 > 其它

[数论] POJ 3090/HOJ 2416 Visible Lattice Points 欧拉函数

2014-02-10 13:03 507 查看
传送门:Visible Lattice Points

Visible Lattice Points

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5126 Accepted: 2978
Description

A lattice point (xy) in the first quadrant (x and y are integers greater than or equal to 0), other than the origin, is visible from the origin if the
line from (0, 0) to (xy) does not pass through any other lattice point. For example, the point (4, 2) is not visible since the line from the origin passes through (2, 1). The figure below shows the points
(xy) with 0 ≤ xy ≤ 5 with lines from the origin to the visible points.



Write a program which, given a value for the size, N, computes the number of visible points (xy) with 0 ≤ xy ≤ N.

Input

The first line of input contains a single integer C (1 ≤ C ≤ 1000) which is the number of datasets that follow.

Each dataset consists of a single line of input containing a single integer N (1 ≤ N ≤ 1000), which is the size.

Output

For each dataset, there is to be one line of output consisting of: the dataset number starting at 1, a single space, the size, a single space and the number of visible points for that size.

Sample Input
4
2
4
5
231

Sample Output
1 2 5
2 4 13
3 5 21
4 231 32549

Source

Greater New York 2006

解题报告:

先画一条(0, 0)到(n, n)的线,把图分成两部分,两部分是对称的,只需算一部分就好。

取右下半,这一半里的点(x, y)满足x >= y

可以通过欧拉函数计算第k列有多少点能够连到(0, 0)

若x与k的最大公约数d > 1,则(0, 0)与(x, k)点的连线必定会通过(x/d, k/d),就被挡住了

所以能连的线的数目就是比k小的、和k互质的数的个数,然后就是欧拉函数。

代码如下:

#include<stdio.h>
int eular(int n){
int ret=1,i;
for(i=2;i*i<=n;i++)
if (n%i==0){
n/=i,ret*=i-1;
while (n%i==0)
n/=i,ret*=i;
}
if (n>1)
ret*=n-1;
return ret; //n的欧拉数
}
int main(){
int test;
int n;
int i;
int ans;
int t=0;
scanf("%d",&test);
while(test--){
ans=0;
scanf("%d",&n);
for(i=2;i<=n;i++)
ans+=eular(i);
printf("%d %d %d\n",++t,n,ans*2+3);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  数论 欧拉函数