您的位置:首页 > 其它

HDU-3047

2020-05-11 04:11 267 查看

In 12th Zhejiang College Students Games 2007, there was a new stadium built in Zhejiang Normal University. It was a modern stadium which could hold thousands of people. The audience Seats made a circle. The total number of columns were 300 numbered 1–300, counted clockwise, we assume the number of rows were infinite.
These days, Busoniya want to hold a large-scale theatrical performance in this stadium. There will be N people go there numbered 1–N. Busoniya has Reserved several seats. To make it funny, he makes M requests for these seats: A B X, which means people numbered B must seat clockwise X distance from people numbered A. For example: A is in column 4th and X is 2, then B must in column 6th (6=4+2).
Now your task is to judge weather the request is correct or not. The rule of your judgement is easy: when a new request has conflicts against the foregoing ones then we define it as incorrect, otherwise it is correct. Please find out all the incorrect requests and count them as R.
Input
There are many test cases:
For every case:
The first line has two integer N(1<=N<=50,000), M(0<=M<=100,000),separated by a space.
Then M lines follow, each line has 3 integer A(1<=A<=N), B(1<=B<=N), X(0<=X<300) (A!=B), separated by a space.

Output
For every case:
Output R, represents the number of incorrect request.
Sample Input
10 10
1 2 150
3 4 200
1 5 270
2 6 200
6 5 80
4 7 150
8 9 100
4 8 50
1 7 100
9 2 100
Sample Output
2
题意
有一个300行无穷列的座位
给出顺时针依次给出两个人之间的距离问有几个说法是错误的
带权值并查集

在这里插入代码片
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
typedef long long ll;
const int N=50020;
int f[N],d[N],n;
void init()
{
for(int i=1; i<=n; i++)
{
f[i]=i;
d[i]=0;
}
}
int getf(int x)
{
if(f[x]==x)
return x;
else
{
int t=f[x];//找它的父节点
f[x]=getf(f[x]);
d[x]=d[x]+d[t];///d[x](为x到根节点的距离)更新为它到它父节点的距离+父节点到根节点的距离
return f[x];
}
}
void merge(int x,int y)
{
int t1=getf(x);
int t2=getf(y);
if(t1!=t2)
f[t2]=t1;
return;
}

int main()
{
int m,x,y,z;
while(~scanf("%d %d",&n,&m))
{
init();
int ans=0;
for(int i=0; i<m; i++)
{
scanf("%d %d %d",&x,&y,&z);
int fx=getf(x),fy=getf(y);
if(fx==fy)
{
int w=d[y]-d[x];
if(w!=z)
ans++;
}
else
{
merge(x,y); ///f[fy]=x;
d[fy]=d[x]+z-d[y];
}
}
printf("%d\n",ans);
}
return 0;
}
Starry_Sky_Dream 原创文章 50获赞 4访问量 2352 关注 私信
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: