您的位置:首页 > 大数据 > 人工智能

PAT 甲级 1106 Lowest Price in Supply Chain (25分)

2020-04-22 13:40 531 查看

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one’s supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the lowest price a customer can expect from some retailers.
Input Specification:
Each input file contains one test case. For each case, The first line contains three positive numbers: N (≤10​0000), the total number of the members in the supply chain (and hence their ID’s are numbered from 0 to N−1, and the root supplier’s ID is 0); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:
K​iID[1] ID[2] … ID[K​i​​ ]
where in the i-th line, K​i​​ is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID’s of these distributors or retailers. K​j being 0 means that the j-th member is a retailer. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print in one line the lowest price we can expect from some retailers, accurate up to 4 decimal places, and the number of retailers that sell at the lowest price. There must be one space between the two numbers. It is guaranteed that the all the prices will not exceed 10^10​​ .
Sample Input:
10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0
2 6 1
1 8
0
0
0
Sample Output:
1.8362 2
题意:找到离根结点最近的叶子结点并计算该层的叶子结点数;
分为两步,第一步找到根结点,第二部通过DFS(BFS也行)遍历整个树;
AC代码:

#include<iostream>
#include<vector>
#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn=100001;
int mindepth=100001;
int n,num=0;
double p,r;
struct Node{
bool isroot=true;//判断是否是根结点
vector<int>child;//孩子结点
}node[maxn];
int findroot(){
for(int i=0;i<n;i++){
if(node[i].isroot==true){
return i;
break;
}}
return n;
}
void   dfs(int index,int depth){
if(node[index].child.size()==0){//若为叶子结点
if(depth<mindepth){
mindepth=depth;
num=1;}
else if(depth==mindepth){
num++;}
return;}
else{//不是叶节点
for(int i=0;i<node[index].child.size();i++){
dfs(node[index].child[i],depth+1);
}}}
double pow(int s){
for(int i=0;i<s;i++){
p*=(1+r/100);
}}
int main(){
int root,x1,x2;
scanf("%d %lf %lf",&n,&p,&r);
for(int i=0;i<n;i++){
scanf("%d",&x1);
for(int j=0;j<x1;j++){
scanf("%d",&x2);
node[x2].isroot=false;
node[i].child.push_back(x2);}}
root=findroot();
dfs(root,0);
pow(mindepth);
printf("%.4f %d",p,num);
system("pause");
return 0;}
  • 点赞
  • 收藏
  • 分享
  • 文章举报
Seqlist_base 发布了18 篇原创文章 · 获赞 1 · 访问量 500 私信 关注
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: