您的位置:首页 > 大数据 > 人工智能

PAT 1106 Lowest Price in Supply Chain

2019-02-17 12:15 267 查看

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the lowest price a customer can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (≤10​5​​), the total number of the members in the supply chain (and hence their ID's are numbered from 0 to N−1, and the root supplier's ID is 0); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

K​i​​ ID[1] ID[2] ... ID[K​i​​]

where in the i-th line, K​i​​ is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID's of these distributors or retailers. K​j​​ being 0 means that the j-th member is a retailer. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the lowest price we can expect from some retailers, accurate up to 4 decimal places, and the number of retailers that sell at the lowest price. There must be one space between the two numbers. It is guaranteed that the all the prices will not exceed 10​10​​.

Sample Input:

[code]10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0
2 6 1
1 8
0
0
0

Sample Output:

[code]1.8362 2

---------------------------------------这是题目和解题的分割线---------------------------------------

PAT 1090 Highest Price in Supply Chain 和这道题一样,本题求的是最小价格和满足该要求的叶子结点数。

[code]#include<cstdio>
#include<vector>
#include<cmath>
#define maxN 100010

using namespace std;

vector<int> tree[maxN];

//最大层数
int n,minN = maxN,num = 1;
double money,rate;

void dfs(int layer,int index)
{
if(tree[index].size()==0) //叶子结点
{
if(layer<minN)
{
num = 1; //更新最小值并将满足要求的叶子结点置1
minN = layer;
}
else if(layer==minN) num++; //相等++
return;
}
for(int i=0;i<tree[index].size();i++)
dfs(layer+1,tree[index][i]);
}

int main()
{
int i,j,x,child;
scanf("%d%lf%lf",&n,&money,&rate);
rate /= 100;
for(i=0;i<n;i++)
{
scanf("%d",&x);
for(j=0;j<x;j++)
{
scanf("%d",&child);
tree[i].push_back(child);
}
}
dfs(0,0);
printf("%.4f %d\n",money*pow(1+rate,minN),num);
return 0;
}

 

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: