您的位置:首页 > 其它

顺序表应用6:有序顺序表查询

2019-06-25 20:19 68 查看

顺序表应用6:有序顺序表查询
Time Limit: 1000 ms Memory Limit: 4096 KiB
Problem Description

顺序表内按照由小到大的次序存放着n个互不相同的整数,任意输入一个整数,判断该整数在顺序表中是否存在。如果在顺序表中存在该整数,输出其在表中的序号;否则输出“No Found!"。
Input

第一行输入整数n (1 <= n <= 100000),表示顺序表的元素个数;
第二行依次输入n个各不相同的有序非负整数,代表表里的元素;
第三行输入整数t (1 <= t <= 100000),代表要查询的次数;
第四行依次输入t个非负整数,代表每次要查询的数值。

保证所有输入的数都在 int 范围内。
Output

输出t行,代表t次查询的结果,如果找到在本行输出该元素在表中的位置,否则本行输出No Found!
Sample Input

10
1 22 33 55 63 70 74 79 80 87
4
55 10 2 87

Sample Output

4
No Found!
No Found!
10

#include<bits/stdc++.h>

using namespace std;

typedef struct
{
int *elem;
int length;
}List;
void creat(List &l, int n)
{
l.elem = new int[10001];
if(!l.elem) exit(0);
for(int i = 0; i < n; i++)
{
cin>>l.elem[i];
}
l.length = n;
}
int display(List &l, int n)
{
int m, mid, high, low;
cin>>m;
low = 0;
high = n - 1;
while(low <= high)
{
mid = (high + low) / 2;///mid 要每一次都更新
if(l.elem[mid] > m)
{
high = mid - 1;
}
else if(m > l.elem[mid])
{
low = mid + 1;
}
else
return mid;
}
return -1;
}
int main()
{
int x, n, t;
List l;
cin>>n;
creat(l, n);
cin>>t;
while(t–)
{
x = display(l, n);
if(x == -1)
cout<<“No Found!”<<endl;
else
cout<<x + 1<<endl;
}
return 0;
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: