您的位置:首页 > 其它

poj 2352 Stars (树状数组)

2014-03-29 10:59 351 查看
Stars

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 29888Accepted: 13066
Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.
Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.
Source

Ural Collegiate Programming Contest 1999

//Accepted    420K    172MS    C++    700B
/*

题意:
给出一些星星的位置,其中每颗星左下方(包括正左和正下)的数量为
该星星的级数,问每个级数的星星有几颗。

树状数组:
入门题。因为数据是由y轴递增的,因此只计算x轴的即可。
a[i]表示第i级的星星的个数,c[i]表示第1级到第i级的星星
个数之和。每次计算再更新,因为级数计算不包括本身。

*/
#include<stdio.h>
#include<string.h>
#define N 35000
int a
,c
;
int lowbit(int i)
{
return i&(-i);
}
void insert(int k,int detal)
{
for(;k<=N;k+=lowbit(k))
c[k]+=detal;
}
int getsum(int k) //a[1]+..+a[k]
{
int t=0;
for(;k>0;k-=lowbit(k))
t+=c[k];
return t;
}
int main(void)
{
int n,x,y;
while(scanf("%d",&n)!=EOF)
{
memset(a,0,sizeof(a));
memset(c,0,sizeof(c));
for(int i=0;i<n;i++){
scanf("%d%d",&x,&y);
x++;  //树状数组坐标由1开始
a[getsum(x)]++;
insert(x,1);
}
for(int i=0;i<n;i++) printf("%d\n",a[i]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: