您的位置:首页 > 其它

HDU - 1045 - Fire Net (DFS)

2018-03-20 17:52 357 查看
Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot.
4000
The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.

Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.

Input

The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a ‘.’ indicating an open space and an uppercase ‘X’ indicating a wall. There are no spaces in the input file.

Output

For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.

Sample Input

4

.X..

….

XX..

….

2

XX

.X

3

.X.

X.X

.X.

3



.XX

.XX

4

….

….

….

….

0

Sample Output

5

1

5

2

4

跟着kuangbin刷的,上面说用二分图匹配算法来做,前面用这算法一直答案错误,用DFS直接可以过

#include <bits/stdc++.h>
using namespace std;
int ans=0;
int n;
int g[5][5];
char c;
bool judge(int x,int y)
{
if(g[x][y]==2||g[x][y]==0)
return false;
for(int a = x; a>= 1; a --)
if(g[x][a]==0)
break;
else if(g[x][a]==2)
return false;
for(int a = x; a<= n; a ++)
if(g[x][a]==0)
break;
else if(g[x][a]==2)
return false;
for(int a = y; a>= 1; a --)
if(g[a][y]==0)
break;
else if(g[a][y]==2)
return false;
for(int a = y; a<= n; a ++)
if(g[a][y]==0)
break;
else if(g[a][y]==2)
return false;
return true;
}
void dfs(int num)//这个函数取巧了,卡数据小,不然肯定会TLE
{
if(num>ans) ans=num;
for(int a = 1; a <= n; a ++)
for(int b = 1; b <= n; b ++)
if(judge(a,b))
{
g[a][b]=2;
dfs(num+1);
g[a][b]=1;
}
}
int main()
{
while(scanf("%d\n",&n))
{
if(n==0)
break;
memset(g,0,sizeof(g));
for(int a = 1; a <= n; a ++)
{
for(int b = 1; b <= n; b ++)
{
scanf("%c",&c);
if(c=='X')
g[a][b]=0;
else
g[a][b]=1;
}
getchar();
}
ans=0;
dfs(0);
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: