您的位置:首页 > 其它

HDU1045 Fire Net(深搜DFS)

2017-01-08 08:59 381 查看
题目:


Fire Net

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 10991    Accepted Submission(s): 6518


Problem Description

Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall. 

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening. 

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets. 

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least
one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through. 

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses
in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways. 



Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration. 

 

Input

The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The
next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file. 

 

Output

For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.

 

Sample Input

4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0

 

Sample Output

5
1
5
2
4

 

Source

Zhejiang University Local Contest 2001

 

Recommend

 

Statistic | Submit | Discuss | Note
思路:

此题给了一个地图,然后地图上面有墙,类似玩的泡泡堂游戏,放置大炮。一个大炮可以炸横列和纵列,如果碰到墙,那么就不能继续延伸,问最多可以放多少大炮才能使,大炮可以炸到全场,大炮必须互相不在攻击范围,思路是深搜每一个点,分别放置大炮和不放大炮,最终来求最大值

代码:

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <stack>
#include <queue>
#include <vector>
#include <cmath>
#include <algorithm>
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
char map[15][15];
int n,maxx;
int judge(int x,int y)//判读这一点能否防止大炮
{
for(int i=y; i>=0; i--)
{
if(map[x][i]=='X')break;//如果横向碰到墙,就跳出
if(map[x][i]=='P')return 0;//如果遇到大炮就返回0
}
for(int i=x; i>=0; i--)
{
if(map[i][y]=='X')break;//如果纵向碰到墙就跳出
if(map[i][y]=='P')return 0;//如果遇到大炮就返回0
}
return 1;//只有两个同时跳出可以返回1
}
void dfs(int num,int step)//num代表当前的点,step代表大炮数量
{
if(num==n*n)//判断是否搜完了所有的点
{
if(step>maxx)
maxx=step;//更新最大值
return;
}
int x=num/n,y=num%n;
if(map[x][y]=='.'&&judge(x,y))//判断该点非墙且可以防置大炮
{
map[x][y]='P';//放大炮
dfs(num+1,step+1);
map[x][y]='.';
}
dfs(num+1,step);//当这一点不放大炮时
}
int main()
{
while(~scanf("%d",&n)&&n)
{
maxx=0;//把能防置的大炮初始化
for(int i=0; i<n; i++)
scanf("%s",map[i]);//读入地图
dfs(0,0);//从第一个点开始搜索
printf("%d\n",maxx);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: