您的位置:首页 > 其它

1118. Birds in Forest (25)

2018-03-02 15:45 411 查看

1118. Birds in Forest (25)

时间限制150 ms
内存限制65536 kB
代码长度限制16000 B
判题程序Standard作者CHEN, Yue
Some scientists took pictures of thousands of birds in a forest. Assume that all the birds appear in the same picture belong to the same tree. You are supposed to help the scientists to count the maximum number of trees in the forest, and for any pair of birds, tell if they are on the same tree.Input Specification:Each input file contains one test case. For each case, the first line contains a positive number N (<= 104) which is the number of pictures. Then N lines follow, each describes a picture in the format:
K B1 B2 ... BK
where K is the number of birds in this picture, and Bi's are the indices of birds. It is guaranteed that the birds in all the pictures are numbered continuously from 1 to some number that is no more than 104.After the pictures there is a positive number Q (<= 104) which is the number of queries. Then Q lines follow, each contains the indices of two birds.Output Specification:For each test case, first output in a line the maximum possible number of trees and the number of birds. Then for each query, print in a line "Yes" if the two birds belong to the same tree, or "No" if not.Sample Input:
4
3 10 1 2
2 3 4
4 1 5 7 8
3 9 6 4
2
10 5
3 7
Sample Output:
2 10
Yes
No
并查集#include<stdio.h>
#include<algorithm>
using namespace std;
int tree[10010];
void init(){
for(int i=1;i<=10010;i++){//...
tree[i]=-1;
}
}
int findroot(int x){
if(tree[x]==-1)return x;
return tree[x]=findroot(tree[x]);
}
int main(){
int n,maxn=-1,i,j,k,root,temp,cou=0;
scanf("%d",&n);
init();
for(i=0;i<n;i++){
scanf("%d %d",&k,&root);
maxn=max(maxn,root);
for(j=0;j<k-1;j++){
scanf("%d",&temp);
tree[findroot(temp)]=root;//.. 根指向根
maxn=max(maxn,temp);
}
}
for(i=1;i<=maxn;i++){
if(tree[i]==-1){
cou++;
}
}
printf("%d %d\n",cou,maxn);
int q,c1,c2;
scanf("%d",&q);
for(i=0;i<q;i++){
scanf("%d %d",&c1,&c2);
c1=findroot(c1);
c2=findroot(c2);
if(c1==c2){
printf("Yes\n");
}
else{
printf("No\n");
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: