您的位置:首页 > Web前端 > Node.js

1115. Counting Nodes in a BST (30)

2018-03-01 14:35 253 查看

1115. Counting Nodes in a BST (30)

时间限制400 ms
内存限制65536 kB
代码长度限制16000 B
判题程序Standard作者CHEN, Yue
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:The left subtree of a node contains only nodes with keys less than or equal to the node's key.
The right subtree of a node contains only nodes with keys greater than the node's key.
Both the left and right subtrees must also be binary search trees.
Insert a sequence of numbers into an initially empty binary search tree. Then you are supposed to count the total number of nodes in the lowest 2 levels of the resulting tree.Input Specification:Each input file contains one test case. For each case, the first line gives a positive integer N (<=1000) which is the size of the input sequence. Then given in the next line are the N integers in [-1000 1000] which are supposed to be inserted into an initially empty binary search tree.Output Specification:For each case, print in one line the numbers of nodes in the lowest 2 levels of the resulting tree in the format:n1 + n2 = nwhere n1 is the number of nodes in the lowest level, n2 is that of the level above, and n is the sum.Sample Input:
9
25 30 42 16 20 20 35 -5 28
Sample Output:
2 + 4 = 6

#include<stdio.h>
#include<stdlib.h>
typedef struct Node *node;
int deepest;
int cou[1010];
struct Node{
int x;
node left;
node right;
};
node insert(node T,int x){
if(T==0){
T=(node)malloc(sizeof(struct Node));//...
T->x=x;
T->left=T->right=0;//NULL
}
else if(x<=T->x){
T->left=insert(T->left,x);
}
else{
T->right=insert(T->right,x);
}
return T;
}
void dfs(node T,int depth){
if(T){
cou[depth]++;
if(depth>deepest){
deepest=depth;
}
dfs(T->left,depth+1);
dfs(T->right,depth+1);
}
}
int main(){
int n,i,x;
scanf("%d",&n);
node T=0;//NULL
for(i=0;i<n;i++){
scanf("%d",&x);
T=insert(T,x);
}
dfs(T,1);
printf("%d + %d = %d",cou[deepest],cou[deepest-1],cou[deepest]+cou[deepest-1]);
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: