您的位置:首页 > Web前端 > Node.js

PAT - 甲级 - 1115. Counting Nodes in a BST (30)(建树+记录结点个数)

2017-03-29 10:59 363 查看
题目描述:

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than or equal to the node's key.
The right subtree of a node contains only nodes with keys greater than the node's key.
Both the left and right subtrees must also be binary search trees.
Insert a sequence of numbers into an initially empty binary search tree. Then you are supposed to count the total number of nodes in the lowest 2 levels of the resulting tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=1000) which is the size of the input sequence. Then given in the next line are the N integers in [-1000 1000] which are supposed to be inserted into an initially
empty binary search tree.

Output Specification:

For each case, print in one line the numbers of nodes in the lowest 2 levels of the resulting tree in the format:

n1 + n2 = n

where n1 is the number of nodes in the lowest level, n2 is that of the level above, and n is the sum.

Sample Input:
9
25 30 42 16 20 20 35 -5 28

Sample Output:
2 + 4 = 6


题目思路:

首先建BST树,题目要求输出最后一层和倒数第二层的结点的个数。我们可以用层次遍历的方法,直接记录最后2层的个数。或者直接深搜,记录每个深度的结点个数。这里给出2种方法的代码。

题目代码:

#include <cstdio>
#include <queue>
#include <cstring>
using namespace std;
int ans[10000], maxd;
// Bst结构
struct Bst{
int v;
Bst *lchild, *rchild;
Bst(int v):v(v),lchild(NULL),rchild(NULL){}
};
// 插入建树
void insert(Bst *&root, int v){
if(root == NULL){
root = new Bst(v);
return ;
}
if(v > root->v){
insert(root->rchild, v);
}else{
insert(root->lchild, v);
}
}

void dfs(Bst *root, int d){
if(root == NULL ) return ;
ans[d]++; // 记录每个深度的结点数
maxd = max(maxd,d);
dfs(root->lchild,d+1);
dfs(root->rchild,d+1);
}

int n, v, l1 ,l2;
int main(){
scanf("%d",&n);
memset(ans,0,sizeof(ans));
Bst *root = NULL;
while(n--){
scanf("%d",&v);
insert(root,v);
}
// 深搜
maxd = -1;
dfs(root, 0);

queue<Bst*>q;
q.push(root);
l1 = l2 = 0;
// 层次遍历方法 l1 l2表示最底层和倒数第二层个数
while(!q.empty()){
l2 = l1;
l1 = q.size();
for(int i = 0; i < l1; i++){ //注意这里
Bst *p = q.front();
if(p->lchild != NULL) q.push(p->lchild);
if(p->rchild != NULL) q.push(p->rchild);
q.pop();
}

}
printf("%d + %d = %d\n",ans[maxd],ans[maxd-1],ans[maxd]+ans[maxd-1]);
//	printf("%d + %d = %d\n",l1,l2,l1+l2);

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: