您的位置:首页 > 其它

POJ 1308 Is It A Tree? 并查集 (判断任意2个点是否有且仅有一条路径可以相通)

2018-02-19 10:46 441 查看
A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 

There is exactly one node, called the root, to which no directed edges point. 
Every node except the root has exactly one edge pointing to it. 
There is a unique sequence of directed edges from the root to each node. 
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not. 
In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.
Input
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.
Output
For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).
Sample Input
6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1
Sample Output
Case 1 is a tree.
Case 2 is a tree.

Case 3 is not a tree.

题意:判断通过这些点相连可以达到 任意两个房间有且仅有一条路径可以相通。
思路:因为任意两个房间有且仅有一条路径可以相通,所以只可以有一个根节点,注意寻找根节点的时候的方向问题
(与HDU 1272 一模一样)#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <map>
#include <set>
#include <cmath>
using namespace std;
typedef long long ll;
const int N = 100005;
int flag
;
int parent
;
int root(int x)
{
return parent[x] == x ? x: parent[x]=root(parent[x]);
}
void make(int x,int y)
{
int fx=root(x);
int fy=root(y);
if(fx>fy)
parent[fx]=fy;
else
parent[fy]=fx;
}
int main()
{
int a,b,t=0;
while(scanf("%d%d",&a,&b)==2){
if(a==-1&&b==-1)
break;
for(int i=0;i<=100000;i++)
parent[i]=i;
memset(flag,0,sizeof(flag));
int F=0;
while(1)
{
if(a==0&&b==0)
break;
if(root(a)==root(b)) //如果2个点再次相连则错误
F=1;
make(a,b);
flag[a]=1; //这2个点都到达过
flag[b]=1;
scanf("%d%d",&a,&b);
}
printf("Case %d ",++t);
if(F==1)
printf("is not a tree.\n");
else{
int sum=0;
for(int i=0;i<=100000;i++)
if(flag[i]&&parent[i]==i) //记录根节点的个数
sum++;
if(sum>1)
printf("is not a tree.\n");
else
printf("is a tree.\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐