您的位置:首页 > 其它

【 数论 Nim博弈 】POJ 2234 Matches Game

2018-02-04 22:24 423 查看
Matches Game

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10865 Accepted: 6339
Description
Here is a simple game. In this game, there are several piles of matches and two players. The two player play in turn. In each turn, one can choose a pile and take away arbitrary number of matches from the pile (Of
course the number of matches, which is taken away, cannot be zero and cannot be larger than the number of matches in the chosen pile). If after a player’s turn, there is no match left, the player is the winner. Suppose that the two players are all very clear.
Your job is to tell whether the player who plays first can win the game or not.
Input
The input consists of several lines, and in each line there is a test case. At the beginning of a line, there is an integer M (1 <= M <=20), which is the number of piles. Then comes M positive integers, which are not
larger than 10000000. These M integers represent the number of matches in each pile.
Output
For each test case, output "Yes" in a single line, if the player who play first will win, otherwise output "No".
Sample Input
2 45 45
3 3 6 9

Sample Output
No
Yes

题意:....n堆石子,每堆个数不一样,每次可以在任意堆拿任意个,问先手赢还是后手赢。
思路:不能再基础的Nim Game 了....

#include<stdio.h>
int main()
{
int n;
while(~scanf("%d",&n))
{
int ans = 0;
while(n--)
{
int x;
scanf("%d",&x);
ans ^= x;//其实这里我暂时也不是很懂,先记下来,以后再深入理解理解
}
if(ans == 0) printf("No\n");//后手赢
else printf("Yes\n");//先手必赢
}
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  数论